Bug 1018484 - [abrt] firewall-config-0.3.5-1.fc19: firewall-config:1572:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'
[abrt] firewall-config-0.3.5-1.fc19: firewall-config:1572:onChangeZone:TypeEr...
Status: CLOSED DUPLICATE of bug 995760
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:d54ce9534ea553f07111c9ec83d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-12 08:50 EDT by Eric Blake
Modified: 2013-10-14 07:23 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 06:40:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (669 bytes, text/plain)
2013-10-12 08:50 EDT, Eric Blake
no flags Details
File: environ (1.77 KB, text/plain)
2013-10-12 08:50 EDT, Eric Blake
no flags Details

  None (edit)
Description Eric Blake 2013-10-12 08:50:14 EDT
Description of problem:
I let the firewall app sit idle for several minutes.  When I returned to it, I think my credentials had expired, because I got a dialog box asking for my password again as well as this abrt report.

Version-Release number of selected component:
firewall-config-0.3.5-1.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.10.7-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            14986

Truncated backtrace:
firewall-config:1572:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 1572, in onChangeZone
    _services = services[:]
TypeError: 'NoneType' object has no attribute '__getitem__'

Local variables in innermost frame:
masquerade: False
default: False
interfaces: ['wlp3s0']
args: (<TreeSelection object at 0x32a8eb0 (GtkTreeSelection at 0x2f70770)>,)
self: <__main__.FirewallConfig object at 0x2e1bd50>
sources: []
builtin: False
icmpblocks: []
rules: []
services: None
active_zone: 'public'
ports: [['5900', 'tcp'], ['24800', 'tcp'], ['5900', 'udp']]
forward_ports: []
Comment 1 Eric Blake 2013-10-12 08:50:18 EDT
Created attachment 811570 [details]
File: backtrace
Comment 2 Eric Blake 2013-10-12 08:50:21 EDT
Created attachment 811571 [details]
File: environ
Comment 3 Jiri Popelka 2013-10-14 06:40:56 EDT
(In reply to Eric Blake from comment #0)
> Description of problem:
> I let the firewall app sit idle for several minutes.  When I returned to it,
> I think my credentials had expired, because I got a dialog box asking for my
> password again as well as this abrt report.

I'll try that, thanks.

*** This bug has been marked as a duplicate of bug 995760 ***
Comment 4 Jiri Popelka 2013-10-14 07:23:25 EDT
hmm, no luck :-(

Note You need to log in before you can comment on or make changes to this bug.