Bug 1018485 - EclipseLink 2.5.1 is available
EclipseLink 2.5.1 is available
Product: Fedora
Classification: Fedora
Component: eclipselink (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: gil cattaneo
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-10-12 09:52 EDT by Gerard Ryan
Modified: 2015-11-04 08:33 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.5.2-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-10-12 10:40:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2013-10-12 09:52:42 EDT
Description of problem:
Latest release of eclipselink in rawhide & f20 is 2.4.2, and in f19 is 2.3.2. Eclipselink 2.5.1 was released in late September [0].

Since eclipselink 2.5.x is part of Kepler simultaneous release[1], and 2.5.1 came out with Kepler SR1, I wonder if we should have 2.5.1 everywhere we have eclipse 4.3.1 and other eclipse projects that came with SR1 release?

I think we should have it for rawhide/f20, and maybe f19 too.

[0] http://www.eclipse.org/eclipselink/releases/2.5.php
[1] http://projects.eclipse.org/releases/kepler
Comment 1 gil cattaneo 2013-10-12 10:40:04 EDT
i dont want upgrade to this version until Spring Framework deped on jpa 2.0
and this "new" release provides incompatible apis (jpa 2.1)
Comment 2 gil cattaneo 2015-11-04 08:33:12 EST
Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=11699535

Note You need to log in before you can comment on or make changes to this bug.