Bug 1018520 - rsyncd.socket does not work
rsyncd.socket does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rsync (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Luscon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1047236
  Show dependency treegraph
 
Reported: 2013-10-12 17:00 EDT by Andrew J. Schorr
Modified: 2013-12-30 13:19 EST (History)
6 users (show)

See Also:
Fixed In Version: rsync-3.0.9-12.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1047236 (view as bug list)
Environment:
Last Closed: 2013-10-23 20:54:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew J. Schorr 2013-10-12 17:00:42 EDT
Description of problem: The systemd rsyncd.socket unit does not work.  It says "Accept=yes".  According to "man systemd.socket", when Accept is set to yes,
there must be an accompanying rsyncd@.service file.  But there is no such file 
in the rpm.  Instead, we have rsyncd.service, which works fine on a standalone
basis without using the rsyncd.socket unit.  But it would be nice if
rsyncd.socket were to work so I wouldn't need to leave the rsyncd server
running all the time.


Version-Release number of selected component (if applicable):
rsync-3.0.9-8.fc19.x86_64


How reproducible:
Try "systemctl start rsyncd.socket" and then try to connect
to the rsync service.  For example, you can simply try "telnet localhost rsync",
and you will see that it exits immediately and "systemctl status rsyncd.socket" shows that it has failed.

Steps to Reproduce:
1. systemctl start rsyncd.socket
2. telnet localhost rsync
3.

Actual results: The connection is closed, and "systemctl status rsyncd.service"
says that it has failed.  And this error message is logged:

Oct 12 16:57:47 ti19 systemd[1]: rsyncd.socket failed to queue service startup job (Maybe the service file is missing or not a template unit?): Invalid argument



Expected results: It should work!  An rsyncd@.service unit should
be packaged with this rpm.


Additional info:
Comment 1 Fedora Update System 2013-10-20 14:13:10 EDT
rsync-3.0.9-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rsync-3.0.9-12.fc19
Comment 2 Fedora Update System 2013-10-22 01:02:50 EDT
Package rsync-3.0.9-12.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rsync-3.0.9-12.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19664/rsync-3.0.9-12.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-10-23 20:54:05 EDT
rsync-3.0.9-12.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Jef Spaleta 2013-12-29 14:34:13 EST
Morning,

I've heard reports that rsyncd.socket isn't working in F20.  Just a little friendly heads up. Does the fix in the update here need to be applied in F20 as well?   I haven't had a chance to confirm this myself and I won't due to my travel schedule. But I just wan't to ping here and let you know so you can choose to review the f20 package to see if it needs adjusted systemd unit files.

-jef
Comment 5 Adam Williamson 2013-12-30 13:19:35 EST
The f20 package changelog alleges that this is fixed:

http://koji.fedoraproject.org/koji/buildinfo?buildID=472656

* Sun Oct 20 2013 Michal Lusocn <mluscon@redhat.com> - 3.1.0-2 
- Update to latest upstream 3.1.0 
- Fixed #1018520 - missing rsyncd@.service

but yeah, it sounds like perhaps it isn't, from the 'reports' to which you refer ;)

Note You need to log in before you can comment on or make changes to this bug.