Bug 1018525 - Enh: Support python 3 package
Enh: Support python 3 package
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-ethtool (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
: FutureFeature, Reopened
Depends On:
Blocks: PYTHON3-UPSTREAM
  Show dependency treegraph
 
Reported: 2013-10-12 19:00 EDT by Andy Grover
Modified: 2017-06-23 10:19 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-ethtool-0.13-1.fc27 python-ethtool-0.13-1.fc26
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-23 10:19:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dist-git patch (6.63 KB, patch)
2017-06-13 12:18 EDT, Miro Hrončok
no flags Details | Diff
dist-git patch (6.62 KB, patch)
2017-06-13 12:29 EDT, Miro Hrončok
cstratak: review+
Details | Diff

  None (edit)
Description Andy Grover 2013-10-12 19:00:08 EDT
I'm working on making targetcli package Python 3-compatible. Since python-ethtool is used by targetcli, this requires python-ethool also have a Python 3 version.

Feel free to assign this back to me if you'd like me to take a stab.
Comment 1 David Sommerseth 2013-10-17 18:55:23 EDT
I haven't yet started looking at Python 3 support yet.  First in line was to move it towards libnl-3 and clean up the code a bit.  This has come quite far, but still not released yet.  Planning on a release in the not too far future.

If you have any ideas or thoughts about the complexity to add support for Python 3, I'm all ears.
Comment 2 Andy Grover 2013-10-17 20:27:12 EDT
It doesn't look *too* bad, actually, just some slightly ugly ifdeffing around module init:

http://docs.python.org/3/howto/cporting.html

Whenever you wanted to roll it into your normal development cycle, I'd be happy to help with testing.
Comment 3 Antoni Segura Puimedon 2013-11-14 12:52:35 EST
I submitted a first version of the patch for python 3 compatibility:
https://lists.fedorahosted.org/pipermail/python-ethtool-devel/2013/000022.html
Comment 4 Petr Viktorin 2016-01-16 09:57:33 EST
Hello; what is the status of this bug?

I see there was a new patchset posted on the mailing list in 2014, with no reply: https://lists.fedorahosted.org/archives/list/python-ethtool-devel%40lists.fedorahosted.org/2014/10/
Comment 5 Gennadii Altukhov 2016-05-04 04:29:29 EDT
Hello David,

I would like to know the status of this bug because Spacewalk project uses ethtool, and now we need it for Python 3. Do you need any help with this bug?
Comment 6 David Sommerseth 2016-05-12 07:44:56 EDT
Re-assigning this bz to Gennadii Altukhov, as he will take over the maintenance of python-ethtool
Comment 7 Lumír Balhar 2016-07-18 08:26:07 EDT
Hello.

Is there any progress? Do you need help?

Have a nice day.
Lumir
Comment 8 Gennadii Altukhov 2016-07-18 08:39:55 EDT
Hello Lumir,

I will apply patches in near future. Sorry for the delay.
Comment 9 Charalampos Stratakis 2016-08-17 10:28:13 EDT
Upstream maintainer has pushed commits for Python 3 support and released a new version, all that remains is porting of the SPEC file.
Comment 10 Charalampos Stratakis 2016-09-08 05:14:59 EDT
Also the setup.py upstream needs to be modified for the new version.

Created a ticket here:
https://fedorahosted.org/python-ethtool/ticket/2
Comment 11 Charalampos Stratakis 2016-09-14 12:02:21 EDT
Checked the code and still a lot of changes need to be made upstream. With latest commits only the C parts of the code are python 3 compatible.

Changing to block the upstream tracker
Comment 12 Lumír Balhar 2017-05-15 06:45:16 EDT
Hello.

We did some changes in source code and now we have python-ethtool version 0.12 which should be Python 2/3 compatible.

Could you please try to build it respectively make separated subpackages for Python 2 and 3? If you need help, there is a guide for porting RPM packages [0] and/or we can help you of course.

Have a nice day.

[0] https://python-rpm-porting.readthedocs.io/en/latest/application-modules.html#
Comment 13 Miro Hrončok 2017-06-13 11:35:57 EDT
Taking over this. Just release ethtool 0.13 on PyPI and will update the package in rawhide and F26 soon. Speak against it now or never :D
Comment 14 Miro Hrončok 2017-06-13 12:18 EDT
Created attachment 1287378 [details]
dist-git patch

Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=20012215
Comment 15 Miro Hrončok 2017-06-13 12:21:19 EDT
I see I've used python-setuptools. Will change that to python2-setuptools.
Comment 16 Miro Hrončok 2017-06-13 12:22:39 EDT
arm failure. will resubmit.
Comment 17 Miro Hrončok 2017-06-13 12:29 EDT
Created attachment 1287381 [details]
dist-git patch

Working Koji scratch build: https://koji.fedoraproject.org/koji/taskinfo?taskID=20012263
Comment 18 Charalampos Stratakis 2017-06-20 11:02:14 EDT
Patch LGTM. Tested on mock as well and everything is working as expected under python3. No regressions noted and the respective modules import successfully under python2 and python3.
Comment 20 Fedora Update System 2017-06-20 12:28:11 EDT
python-ethtool-0.13-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6b1e4c28dc
Comment 21 Fedora Update System 2017-06-21 02:24:25 EDT
python-ethtool-0.13-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6b1e4c28dc
Comment 22 Fedora Update System 2017-06-23 10:19:51 EDT
python-ethtool-0.13-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.