Bug 1018543 - etcd bundles golang library github.com/jteeuwen/go-bindata which should be unbundled [NEEDINFO]
etcd bundles golang library github.com/jteeuwen/go-bindata which should be un...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: etcd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Cypret
Fedora Extras Quality Assurance
:
Depends On: 1018542
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-13 01:05 EDT by Lokesh Mandvekar
Modified: 2014-12-19 09:20 EST (History)
4 users (show)

See Also:
Fixed In Version: etcd-0.1.2-5.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1018477
Environment:
Last Closed: 2014-12-19 09:20:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mattdm: needinfo? (lacypret)


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2013-10-13 01:05:56 EDT
Subj.
Comment 1 Matthew Miller 2013-10-14 14:00:30 EDT
It looks like go-bindata (being packaged as bug #1018542) is actually only used as part of building the Dashboard, under mod/dashboard, and unless I'm missing it we're _not_ currently building that in the etcd package.

I think we _should_ package that (as a new etcd subpackage?) but I'm not sure what to do with this bug in the meantime. Maybe it should be changed to "package etcd dashboard module", with a note that it should use go-bindata from bug #1018542 rather than the bundled one (e.g. don't use the included build script).
Comment 2 Peter Lemenkov 2013-10-20 06:18:36 EDT
Yes, this looks like a FutureFeature to me. Anyway this shouldn't block #1018477
Comment 4 Peter Lemenkov 2014-12-19 09:20:23 EST
No longer necessary. Upstream is no longer using this library in etcd.

Note You need to log in before you can comment on or make changes to this bug.