Bug 1018565 - scanimage detects sm3840 only for root
scanimage detects sm3840 only for root
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
20
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
RejectedFreezeException
: Reopened
Depends On:
Blocks: F20BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-10-13 07:37 EDT by nucleo
Modified: 2013-12-10 01:08 EST (History)
5 users (show)

See Also:
Fixed In Version: sane-backends-1.0.24-7.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:51:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
udevadm-info-"$(hostname)".1.out (658 bytes, text/plain)
2013-10-23 10:05 EDT, nucleo
no flags Details
udevadm-info-"$(hostname)".1.out with sane-backends-1.0.23-18.fc20 (826 bytes, text/plain)
2013-10-23 10:09 EDT, nucleo
no flags Details

  None (edit)
Description nucleo 2013-10-13 07:37:10 EDT
Description of problem:
'scanimage -L' can detect sm3840 'Microtek ScanMaker 3840 flatbed scanner' only if it runs under roor user.

Version-Release number of selected component (if applicable):
sane-backends-1.0.24-1.fc20

How reproducible:
Always.

Additional info:
With sane-backends-1.0.23-18.fc20 scanner detected for non-root user.

This updates should not be pushed to stable until bug not fixed
https://admin.fedoraproject.org/updates/FEDORA-2013-18730
https://admin.fedoraproject.org/updates/FEDORA-2013-18775
https://admin.fedoraproject.org/updates/FEDORA-2013-18815
Comment 1 nucleo 2013-10-16 10:13:26 EDT
Running "udevadm hwdb --update" as root after updating to sane-backends-1.0.24-1 not fixed problem, "scanimage -L" still detects scanner only if run it as root.
Comment 2 nucleo 2013-10-17 07:56:45 EDT
Output of 'strace scanimage -L' with sane-backends-1.0.24-2.fc20


open("/usr/lib/sane/libsane-sm3840.so.1", O_RDONLY) = 11
close(11)                               = 0
open("/usr/lib/sane/libsane-sm3840.so.1", O_RDONLY|O_CLOEXEC) = 11
read(11, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0`!\0\0004\0\0\0"..., 512) = 512
fstat64(11, {st_mode=S_IFREG|0755, st_size=97284, ...}) = 0
mmap2(NULL, 106112, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 11, 0) = 0xb6829000
mmap2(0xb6840000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 11, 0x16000) = 0xb6840000
mmap2(0xb6842000, 3712, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb6842000
close(11)                               = 0
mprotect(0xb6840000, 4096, PROT_READ)   = 0
recvmsg(3, 0xbf99b7a8, 0)               = -1 EAGAIN (Resource temporarily unavailable)
open("/dev/bus/usb/001/006", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/005", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/004", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/003", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/002", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/005/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/004/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/003/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/002/005", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/002/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/usr/lib/sane/libsane-sm3600.so.1", O_RDONLY) = 11



Output of 'strace scanimage -L' with sane-backends-1.0.23-18.fc20


open("/usr/lib/sane/libsane-sm3840.so.1", O_RDONLY|O_CLOEXEC) = 11
read(11, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\220!\0\0004\0\0\0"..., 512) = 512
fstat64(11, {st_mode=S_IFREG|0755, st_size=97316, ...}) = 0
mmap2(NULL, 106112, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 11, 0) = 0xb68bf000
mmap2(0xb68d6000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 11, 0x16000) = 0xb68d6000
mmap2(0xb68d8000, 3712, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0xb68d8000
close(11)                               = 0
mprotect(0xb68d6000, 4096, PROT_READ)   = 0
stat64("/dev/", {st_mode=S_IFDIR|0755, st_size=4540, ...}) = 0
openat(AT_FDCWD, "/dev/", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 11
getdents(11, /* 227 entries */, 32768)  = 4304
getdents(11, /* 0 entries */, 32768)    = 0
close(11)                               = 0
stat64("/dev/usb/", {st_mode=S_IFDIR|0755, st_size=80, ...}) = 0
openat(AT_FDCWD, "/dev/usb/", O_RDONLY|O_NONBLOCK|O_LARGEFILE|O_DIRECTORY|O_CLOEXEC) = 11
getdents(11, /* 4 entries */, 32768)    = 72
getdents(11, /* 0 entries */, 32768)    = 0
close(11)                               = 0
recvmsg(3, 0xbfc78148, 0)               = -1 EAGAIN (Resource temporarily unavailable)
open("/dev/bus/usb/001/006", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/005", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/004", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/003", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/002", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/001/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/005/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/004/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/003/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/dev/bus/usb/002/006", O_RDWR)    = 11
ioctl(11, SNDRV_CTL_IOCTL_TLV_READ or USBDEVFS_GET_CAPABILITIES, 0xb9236130) = 0
write(7, "\1", 1)                       = 1
read(6, "\1", 1)                        = 1
open("/sys/bus/usb/devices/2-2/bConfigurationValue", O_RDONLY) = 12
read(12, "1\n", 4)                      = 2
close(12)                               = 0
write(7, "\1", 1)                       = 1
read(6, "\1", 1)                        = 1
close(11)                               = 0
open("/dev/bus/usb/002/001", O_RDWR)    = -1 EACCES (Permission denied)
open("/usr/lib/sane/libsane-sm3600.so.1", O_RDONLY) = 11
close(11)                               = 0
Comment 3 Nils Philippsen 2013-10-22 11:36:02 EDT
Harald, I'll Cc you to this bug because of your issues you found when testing this update:

https://admin.fedoraproject.org/updates/FEDORA-2013-19260/sane-backends-1.0.24-2.fc19

I have done some tests here and apparently running 'udevadm hwdb --update' doesn't completely bring udevd up to date with regard to its rules and hardware database (at least not persistently). When digging into how udevd sees things ("udevadm info --name=...", "udevadm hwdb --test=...") I've seen libsane_matched=yes labels appearing and disappearing again until I kicked udevd hard with 'udevadm control --reload'.

Nucleo and Harald, since installing the sane-backends update, have you rebooted the machines to which your scanners are attached? If not, can you try 'udevadm control --reload' and either 'udevadm trigger --subsystem-match=usb' or disconnect/reconnect the device? Thanks.
Comment 4 nucleo 2013-10-22 11:41:07 EDT
I rebooted system after updating sane-backebds, then powered on scanner, then 'scanimage -L' runned from usual user showed only webcam device.
Comment 5 Nils Philippsen 2013-10-23 09:40:58 EDT
All, please try the following (and adapt paths, names, accordingly):

1) identify your scanner device in lsusb, the one I'm testing (and I know that it's driver by libsane-hpaio, not sane-backends ;-)) with looks like this:

...
Bus 001 Device 021: ID 03f0:2805 Hewlett-Packard
...

2) Write what udevd knows about the device to a file:

udevadm info --name=bus/usb/001/021 | tee udevadm-info-"$(hostname)".1.out

The result looks about like this:

P: /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1
N: bus/usb/001/021
E: BUSNUM=001
E: DEVNAME=/dev/bus/usb/001/021
E: DEVNUM=021
E: DEVPATH=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1
E: DEVTYPE=usb_device
...

3) Find the corresponding modalias of the device (using the info in P: above).

find /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1 -name modalias

--> /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1/1-1.5.1:1.0/modalias

cat /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.5/1-1.5.1/1-1.5.1:1.0/modalias

--> usb:v03F0p2805d0100dc00dsc00dp00icFFisc00ipFFin00

4) Find out what hwdb thinks of this:

udevadm hwdb --test=usb:v03F0p2805d0100dc00dsc00dp00icFFisc00ipFFin00

That should give a result like this:

ID_VENDOR_FROM_DATABASE=Hewlett-Packard
libsane_matched=yes

5) Step 2) once more (to find out whether you have the same symptoms with udev hwdb that I had):

udevadm info --name=bus/usb/001/021 | tee udevadm-info-"$(hostname)".2.out

6) Attach both udevadm-info-"$(hostname)".1.out and udevadm-info-"$(hostname)".2.out to this bug.

Thanks!
Comment 6 nucleo 2013-10-23 10:05:19 EDT
Created attachment 815430 [details]
udevadm-info-"$(hostname)".1.out

With sane-backends-1.0.24-2.fc20

1) Bus 002 Device 002: ID 05da:30d4 Microtek International, Inc. USB1200 Scanner

2) $ udevadm info --name=bus/usb/002/002 | tee udevadm-info-"$(hostname)".1.out
P: /devices/pci0000:00/0000:00:1d.0/usb2/2-2
N: bus/usb/002/002
E: BUSNUM=002
E: DEVNAME=/dev/bus/usb/002/002
E: DEVNUM=002
E: DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_MODEL=USB_Scanner
E: ID_MODEL_ENC=USB\x20Scanner
E: ID_MODEL_FROM_DATABASE=USB1200 Scanner
E: ID_MODEL_ID=30d4
E: ID_REVISION=0100
E: ID_SERIAL=05da_USB_Scanner
E: ID_USB_INTERFACES=:ffffff:
E: ID_VENDOR=05da
E: ID_VENDOR_ENC=05da
E: ID_VENDOR_FROM_DATABASE=Microtek International, Inc.
E: ID_VENDOR_ID=05da
E: MAJOR=189
E: MINOR=129
E: PRODUCT=5da/30d4/100
E: SUBSYSTEM=usb
E: TYPE=255/255/255
E: USEC_INITIALIZED=53094258

3) $ find /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2 -name modalias
/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/modalias

$ cat /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/modalias
usb:v05DAp30D4d0100dcFFdscFFdpFFicFFiscFFipFFin00

4) $ udevadm hwdb --test=usb:v05DAp30D4d0100dcFFdscFFdpFFicFFiscFFipFFin00
ID_MODEL_FROM_DATABASE=USB1200 Scanner
ID_USB_CLASS_FROM_DATABASE=Vendor Specific Class
ID_USB_PROTOCOL_FROM_DATABASE=Vendor Specific Protocol
ID_USB_SUBCLASS_FROM_DATABASE=Vendor Specific Subclass
ID_VENDOR_FROM_DATABASE=Microtek International, Inc.

5) $ udevadm info --name=bus/usb/002/002 | tee udevadm-info-"$(hostname)".2.out
P: /devices/pci0000:00/0000:00:1d.0/usb2/2-2
N: bus/usb/002/002
E: BUSNUM=002
E: DEVNAME=/dev/bus/usb/002/002
E: DEVNUM=002
E: DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_MODEL=USB_Scanner
E: ID_MODEL_ENC=USB\x20Scanner
E: ID_MODEL_FROM_DATABASE=USB1200 Scanner
E: ID_MODEL_ID=30d4
E: ID_REVISION=0100
E: ID_SERIAL=05da_USB_Scanner
E: ID_USB_INTERFACES=:ffffff:
E: ID_VENDOR=05da
E: ID_VENDOR_ENC=05da
E: ID_VENDOR_FROM_DATABASE=Microtek International, Inc.
E: ID_VENDOR_ID=05da
E: MAJOR=189
E: MINOR=129
E: PRODUCT=5da/30d4/100
E: SUBSYSTEM=usb
E: TYPE=255/255/255
E: USEC_INITIALIZED=53094258


Files udevadm-info-localhost.localdomain.1.out and udevadm-info-localhost.localdomain.2.out identical.
Comment 7 nucleo 2013-10-23 10:09:37 EDT
Created attachment 815433 [details]
udevadm-info-"$(hostname)".1.out with sane-backends-1.0.23-18.fc20

The same steps but with sane-backends-1.0.23-18.fc20

1) Bus 002 Device 002: ID 05da:30d4 Microtek International, Inc. USB1200 Scanner

2) $ udevadm info --name=bus/usb/002/002 | tee udevadm-info-"$(hostname)".1.out
P: /devices/pci0000:00/0000:00:1d.0/usb2/2-2
N: bus/usb/002/002
E: BUSNUM=002
E: DEVNAME=/dev/bus/usb/002/002
E: DEVNUM=002
E: DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_FOR_SEAT=usb-pci-0000_00_1d_0-usb-0_2
E: ID_MODEL=USB_Scanner
E: ID_MODEL_ENC=USB\x20Scanner
E: ID_MODEL_FROM_DATABASE=USB1200 Scanner
E: ID_MODEL_ID=30d4
E: ID_PATH=pci-0000:00:1d.0-usb-0:2
E: ID_PATH_TAG=pci-0000_00_1d_0-usb-0_2
E: ID_REVISION=0100
E: ID_SERIAL=05da_USB_Scanner
E: ID_USB_INTERFACES=:ffffff:
E: ID_VENDOR=05da
E: ID_VENDOR_ENC=05da
E: ID_VENDOR_FROM_DATABASE=Microtek International, Inc.
E: ID_VENDOR_ID=05da
E: MAJOR=189
E: MINOR=129
E: PRODUCT=5da/30d4/100
E: SUBSYSTEM=usb
E: TAGS=:seat:uaccess:
E: TYPE=255/255/255
E: USEC_INITIALIZED=8215965325
E: libsane_matched=yes

3) $ find /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2 -name modalias
/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/modalias

$ cat /sys/devices/pci0000:00/0000:00:1d.0/usb2/2-2/2-2:1.0/modalias
usb:v05DAp30D4d0100dcFFdscFFdpFFicFFiscFFipFFin00

4) $ udevadm hwdb --test=usb:v05DAp30D4d0100dcFFdscFFdpFFicFFiscFFipFFin00
ID_MODEL_FROM_DATABASE=USB1200 Scanner
ID_USB_CLASS_FROM_DATABASE=Vendor Specific Class
ID_USB_PROTOCOL_FROM_DATABASE=Vendor Specific Protocol
ID_USB_SUBCLASS_FROM_DATABASE=Vendor Specific Subclass
ID_VENDOR_FROM_DATABASE=Microtek International, Inc.

5) P: /devices/pci0000:00/0000:00:1d.0/usb2/2-2
N: bus/usb/002/002
E: BUSNUM=002
E: DEVNAME=/dev/bus/usb/002/002
E: DEVNUM=002
E: DEVPATH=/devices/pci0000:00/0000:00:1d.0/usb2/2-2
E: DEVTYPE=usb_device
E: DRIVER=usb
E: ID_BUS=usb
E: ID_FOR_SEAT=usb-pci-0000_00_1d_0-usb-0_2
E: ID_MODEL=USB_Scanner
E: ID_MODEL_ENC=USB\x20Scanner
E: ID_MODEL_FROM_DATABASE=USB1200 Scanner
E: ID_MODEL_ID=30d4
E: ID_PATH=pci-0000:00:1d.0-usb-0:2
E: ID_PATH_TAG=pci-0000_00_1d_0-usb-0_2
E: ID_REVISION=0100
E: ID_SERIAL=05da_USB_Scanner
E: ID_USB_INTERFACES=:ffffff:
E: ID_VENDOR=05da
E: ID_VENDOR_ENC=05da
E: ID_VENDOR_FROM_DATABASE=Microtek International, Inc.
E: ID_VENDOR_ID=05da
E: MAJOR=189
E: MINOR=129
E: PRODUCT=5da/30d4/100
E: SUBSYSTEM=usb
E: TAGS=:seat:uaccess:
E: TYPE=255/255/255
E: USEC_INITIALIZED=8215965325
E: libsane_matched=yes

6) Files udevadm-info-localhost.localdomain.1.out and udevadm-info-localhost.localdomain.2.out identical.
Comment 8 Fabrice Bellet 2013-10-23 11:15:06 EDT
Hi! It seems strange to me, but there may be a bug in the script that generated the file /usr/lib/udev/hwdb.d/20-sane-backends.hwdb, because all entries seem to have duplicated the vendorid into the productid :

[root@helix ~]# egrep ^usb /usr/lib/udev/hwdb.d/20-sane-backends.hwdb | head -10
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
usb:v03F0p03F0*
[root@helix ~]# rpm -qf /usr/lib/udev/hwdb.d/20-sane-backends.hwdb
sane-backends-1.0.24-2.fc20.x86_64
[root@helix ~]# rpm -V sane-backends
[root@helix ~]# 

Creating a local entry in /etc/udev/hwdb.d/20-local.hwdb just for my scanner with the correct string works for me : udevadm hwdb --test=xxx now displays the "libsane_matched=yes" line, the device /dev/bus/usb/yyy/zzz has the right acl, and sane-find-scanner finds it as a regular user.
Comment 9 Nils Philippsen 2013-10-23 11:26:51 EDT
(In reply to Fabrice Bellet from comment #8)
> Hi! It seems strange to me, but there may be a bug in the script that
> generated the file /usr/lib/udev/hwdb.d/20-sane-backends.hwdb, because all
> entries seem to have duplicated the vendorid into the productid :

Good catch, thanks! I'll look into that.
Comment 10 Harald Reindl 2013-10-23 15:59:25 EDT
thank you for CC

yes i rebooted the machine multiple times because i tend to be an early-kernel-tester, often directly after a new release finished it's build on koji

xsane currently tends to start without device selection and select the Logitech webcam, the Canon scanner worked for years and in fact it would be nice finally not ask for the device and ignore the webcam at all :-)

Bus 002 Device 003: ID 0bda:0181 Realtek Semiconductor Corp. 
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 008: ID 03f0:0324 Hewlett-Packard SK-2885 keyboard
Bus 001 Device 007: ID 046d:c045 Logitech, Inc. Optical Mouse
Bus 001 Device 006: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 001 Device 005: ID 046d:0809 Logitech, Inc. Webcam Pro 9000
Bus 001 Device 004: ID 0e8f:0016 GreenAsia Inc. 4 port USB 1.1 hub UH-174
Bus 001 Device 003: ID 04a9:2213 Canon, Inc. CanoScan LiDE 50/LiDE 35/LiDE 40
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Comment 11 Nils Philippsen 2013-10-24 08:39:30 EDT
Fabrice, thanks for spotting this oddity. The sane-desc program which generated the hwdb file really did write the vendor ID twice. I'll build a fixed package shortly.
Comment 12 Nils Philippsen 2013-10-24 08:49:56 EDT
I've proposed this bug as an F20 beta blocker because both a) the new minor release (1.0.24 -- 1.0.23 is missing lots of bug fixes) and b) using hwdb instead of humongous udev rule sets for permission setting needs to be tested by a wide audience.
Comment 13 nucleo 2013-10-24 08:56:23 EDT
sane-backends-1.0.24-3.fc20.i686 detects scanner for non-root user.

$ scanimage -L
[bjnp] create_broadcast_socket: bind socket to local address failed - Cannot assign requested address
device `v4l:/dev/video0' is a Noname Venus USB2.0 Camera virtual device
device `sm3840:libusb:002:002' is a Microtek ScanMaker 3840 flatbed scanner
Comment 14 Fedora Update System 2013-10-24 16:03:59 EDT
sane-backends-1.0.24-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-3.fc19
Comment 15 Fedora Update System 2013-10-24 16:04:09 EDT
sane-backends-1.0.24-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-3.fc20
Comment 16 Fedora Update System 2013-10-24 16:04:17 EDT
sane-backends-1.0.24-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-3.fc18
Comment 17 Fedora Update System 2013-10-25 13:45:39 EDT
Package sane-backends-1.0.24-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sane-backends-1.0.24-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19948/sane-backends-1.0.24-3.fc20
then log in and leave karma (feedback).
Comment 18 Nils Philippsen 2013-10-28 06:43:59 EDT
All: to test this, you may need to "udevadm control --reload" or even restart your machine due to a bug in current udevd which spoils picking up the new rules.
Comment 19 Nils Philippsen 2013-10-28 06:51:27 EDT
NB: I've seen the fix for udevd in dist-git, it should eventually be available with systemd 204-18 or thereabouts.
Comment 20 nucleo 2013-10-28 07:09:31 EDT
For me scanner works immediately after sane-backends update without any additional actions. After reboot it also works.
Comment 21 Mike Ruckman 2013-10-28 13:16:35 EDT
Discussed in 2013-10-28 Blocker Review meeting [1]. Voted as an RejectedFreezeException. This seems unlikely to affect liveimage users and thus, could be fixed by a 0-day update.

[1] http://meetbot.fedoraproject.org/meetbot/meetbot/fedora-blocker-review/2013-10-28/
Comment 22 Nils Philippsen 2013-10-29 06:00:48 EDT
Harald, you've given negative karma to this update, but it seems to me you're suffering from the udevd issue that it's not picking up hwdb changes properly. Did you "udevadm control --reload" or restart your system after applying the update?
Comment 23 Fedora Update System 2013-10-29 09:46:25 EDT
sane-backends-1.0.24-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-4.fc19
Comment 24 Fedora Update System 2013-10-29 09:46:43 EDT
sane-backends-1.0.24-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-4.fc20
Comment 25 Fedora Update System 2013-10-29 09:46:58 EDT
sane-backends-1.0.24-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-4.fc18
Comment 26 Harald Reindl 2013-10-29 16:02:16 EDT
> Harald, you've given negative karma to this update, but it seems to 
> me you're suffering from the udevd issue that it's not picking up 
> hwdb changes properly. Did you "udevadm control --reload" or restart 
> your system after applying the update?

yes i did, but however, from now on it works again
updates are from koji because i am here beta-tester for other
production environments (mostly servers and some workstations)

Oct 29 12:32:10 Updated: hwdata-0.257-1.fc19.noarch
Oct 29 15:22:39 Updated: sane-backends-libs-1.0.24-4.fc19.x86_64
Oct 29 15:22:40 Updated: sane-backends-1.0.24-4.fc19.x86_64
Oct 29 15:22:40 Updated: sane-backends-drivers-scanners-1.0.24-4.fc19.x86_64
Oct 29 15:22:40 Updated: sane-backends-drivers-cameras-1.0.24-4.fc19.x86_64
Comment 27 Fedora Update System 2013-11-06 22:37:31 EST
sane-backends-1.0.24-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 28 Fedora Update System 2013-11-07 07:26:29 EST
sane-backends-1.0.24-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-5.fc19
Comment 29 Fedora Update System 2013-11-07 07:26:46 EST
sane-backends-1.0.24-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-5.fc20
Comment 30 Fedora Update System 2013-11-07 07:27:11 EST
sane-backends-1.0.24-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-5.fc18
Comment 31 Fedora Update System 2013-11-07 23:38:46 EST
Package sane-backends-1.0.24-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sane-backends-1.0.24-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20919/sane-backends-1.0.24-6.fc18
then log in and leave karma (feedback).
Comment 32 Fedora Update System 2013-11-10 02:51:18 EST
sane-backends-1.0.24-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2013-11-20 17:08:18 EST
sane-backends-1.0.24-7.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-7.fc18
Comment 34 Fedora Update System 2013-11-20 17:08:49 EST
sane-backends-1.0.24-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-7.fc19
Comment 35 Fedora Update System 2013-11-20 17:09:16 EST
sane-backends-1.0.24-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sane-backends-1.0.24-7.fc20
Comment 36 Fedora Update System 2013-12-10 01:08:58 EST
sane-backends-1.0.24-7.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.