Bug 1018764 - BPEL Console - Exception thrown in console messages if Executions for last week is selected in execution history tab
BPEL Console - Exception thrown in console messages if Executions for last we...
Status: NEW
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: BPEL Integration (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ---
: 6.1.0
Assigned To: Matej Melko
Matej Melko
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 07:42 EDT by Jiri Sedlacek
Modified: 2015-11-02 03:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Under the BPEL Console's Execution History tab, if you select any of the previous execution, the application throws an exception message.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Sedlacek 2013-10-14 07:42:45 EDT
My steps:

1. deploy some switchyard app with bpel process
2. run this app to run bpel process (several times)
3. log in to bpel console
4. choose execution history
5. choose execution in last week

Exception can be seen in web console log:

2013-10-14 13:41:31,849 [DEBUG] GET: http://localhost:8080/bpel-console-server/rs/history/definition/e2h0dHA6Ly93d3cuamJvc3Mub3JnL2JwZWwvZXhhbXBsZXN9U2F5SGVsbG8tMA==/instances/chart/completed?timespan=Last Week
2013-10-14 13:41:31,867 [FATAL] Uncaught Exception:
java.lang.IllegalArgumentException:
'domain.length' was <= 0: 0
    at Unknown.aF(JsArrayString.java:42)
    at Unknown.pXb(StackTraceCreator.java:366)
    at Unknown.WWd(ArgChecker.java:68)
    at Unknown.Rzd(BinaryMipMapStrategy.java:44)
    at Unknown.Qzd(BinaryMipMapStrategy.java:24)
    at Unknown.Czd(AbstractArrayDataset.java:202)
    at Unknown.Bzd(AbstractArrayDataset.java:108)
    at Unknown.xzd(AbstractArrayDataset.java:98)
    at Unknown.Lzd(ArrayDataset2D.java:16)
    at Unknown.aAd(ChronoscopeDatasetFactory.java:35)
    at Unknown.cXc(DatasetReader.java:56)
    at Unknown.GYc(LoadDatasetsAction.java:45)
    at Unknown.tOc(AbstractRESTAction.java:86)
    at Unknown.tS(Request.java:287)
    at Unknown._S(RequestBuilder.java:393)
    at Unknown.anonymous(XMLHttpRequest.java:258)
    at Unknown.hE(Impl.java:146)
    at Unknown.anonymous(Impl.java:56)
Comment 1 Eric Wittmann 2013-10-21 13:45:53 EDT
I can't reproduce this with ER6 on Linux.  Can you try again and provide perhaps more specific steps to reproduce? 

I tried the steps above using both the loan_approval and say_hello switchyard quickstarts.
Comment 2 Jiri Sedlacek 2013-10-23 07:55:57 EDT
I've tried say_hello qs once again and still can see the exception. I'm using Ubuntu 13.04, Oracle Java 1.7.0_40, chromium-browser. I've tried firefox and outcome is the same.

I followed the steps I'd written above. 

If I can provide any other information for you, let me know.
Comment 3 Rick Wagner 2014-06-12 14:23:05 EDT
Note for Engineering:  Feel free to ping GSS when you work this one, we had a similar case and may have notes we can supply.

Thanks,

Rick
Comment 7 Gomathi Anandan 2015-08-10 11:34:51 EDT
QE need to retest this issue with latest build and update issue.

Note You need to log in before you can comment on or make changes to this bug.