Bug 1018782 - REST-API: Inconsistent schema implementation in PayloadFile
REST-API: Inconsistent schema implementation in PayloadFile
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-restapi (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Juan Hernández
Ilia Meerovich
virt
: TestBlocker
Depends On:
Blocks: 1019618 3.3snap1
  Show dependency treegraph
 
Reported: 2013-10-14 07:59 EDT by Michael Pasternak
Modified: 2014-01-21 17:11 EST (History)
12 users (show)

See Also:
Fixed In Version: is19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1019618 (view as bug list)
Environment:
Last Closed: 2014-01-21 17:11:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20162 None None None Never
oVirt gerrit 20163 None None None Never

  None (edit)
Description Michael Pasternak 2013-10-14 07:59:29 EDT
Description of problem:

Inconsistent schema implementation in PayloadFile (Cloud-Init),
it has inline collection definition while should use collection/resource
pattern and broken naming convention.
Comment 1 Ilanit Stein 2013-10-15 08:23:50 EDT
Added test blocker flag since it fails the payload test.
Comment 4 Ilia Meerovich 2013-10-24 08:23:01 EDT
is19:
1)
  <!-- Files (ISO or VFD files) -->

  <xs:element name="file" type="File"/>
2) No payloadfile stuff anymore
3) Now  generate_ds.py provides correct mapping:
ClassesMapping = {
....
 'file':File,
....
}
and not: 'file:PayloadFile as it was before

So mapping is correct now
Comment 7 Itamar Heim 2014-01-21 17:11:06 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.