This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1018818 - Use community bom for Teiid
Use community bom for Teiid
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 09:02 EDT by Nick Cross
Modified: 2014-07-09 01:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 15:59:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2697 Major Closed Change to use community bom 2014-04-23 07:33:52 EDT

  None (edit)
Description Nick Cross 2013-10-14 09:02:13 EDT
Teiid should import dependencies from the community bom (https://github.com/jboss-integration/jboss-integration-platform-bom/)
Comment 1 JBoss JIRA Server 2013-10-14 14:11:31 EDT
Van Halbert <vhalbert@jboss.org> updated the status of jira TEIID-2697 to Coding In Progress
Comment 2 JBoss JIRA Server 2013-10-14 14:12:14 EDT
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIID-2697

committed change to root pom.xml:  [8.4.x e7168ef] Teiid-2697 change to use jboss-integration bom
Comment 3 JBoss JIRA Server 2013-10-14 14:12:17 EDT
Van Halbert <vhalbert@jboss.org> updated the status of jira TEIID-2697 to Open
Comment 4 JBoss JIRA Server 2013-10-14 14:42:47 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

Is this a dup of TEIID-2298?  On that one there was an issue at the time on why Ramesh didn't pursue it, but I don't see a comment or related email.  Or is it specific to product and shouldn't be merged forward?

When I run the build with this change I see:

Failed to execute goal on project teiid-admin: Could not resolve dependencies for project org.jboss.teiid:teiid-admin:jar:8.4.1: The following artifacts could not be resolved: org.jboss.as:jboss-as-cli:jar:7.2.1.Final-redhat-10, org.jboss.as:jboss-as-controller:jar:7.2.1.Final-redhat-10: Could not find artifact org.jboss.as:jboss-as-cli:jar:7.2.1.Final-redhat-10 in jboss-eap-alpha (http://maven.repository.redhat.com/techpreview/eap6/6.1.0.Alpha1/maven-repository/)

Are there additional repos needed?
Comment 9 JBoss JIRA Server 2013-10-24 14:13:12 EDT
Van Halbert <vhalbert@jboss.org> updated the status of jira TEIID-2697 to Resolved
Comment 10 JBoss JIRA Server 2013-10-24 14:13:12 EDT
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIID-2697

Added community bom's for:

            <groupId>org.jboss.integration-platform</groupId>
            <artifactId>jboss-integration-platform-bom</artifactId>

             <groupId>org.jboss.as</groupId>
             <artifactId>jboss-as-parent</artifactId>
Comment 11 JBoss JIRA Server 2013-10-25 08:06:12 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2697 to Reopened
Comment 12 JBoss JIRA Server 2013-10-25 08:06:12 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

The changes broke the arquillian tests.  From what I recall these had an issue that no arquillian target for EAP was provided, so this may be somewhat messy to fix.
Comment 13 JBoss JIRA Server 2013-10-25 08:24:13 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

It looks like if we just add back the arquillian version and a few more overrides it works as expected.  Can this go back to 8.4.1 as well?
Comment 14 JBoss JIRA Server 2013-10-25 08:32:37 EDT
Van Halbert <vhalbert@jboss.org> made a comment on jira TEIID-2697

Back porting to 8.4.1 would be good.
Comment 15 JBoss JIRA Server 2013-10-25 08:45:48 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2697 to Resolved
Comment 16 JBoss JIRA Server 2013-10-25 08:45:48 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

updated the parent and test common poms for arquillian to run.
Comment 17 JBoss JIRA Server 2013-10-25 12:54:22 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

this also broke the cassandra kitting by forcing the managed version of jackson
Comment 18 JBoss JIRA Server 2013-10-25 12:58:49 EDT
Ramesh Reddy <rareddy@jboss.org> made a comment on jira TEIID-2697

ah! I was looking into fixing the deployment and was not sure why it was occurring?
Comment 19 JBoss JIRA Server 2013-10-25 13:48:31 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2697

changed the cassandra module.xml to use the managed jackson version 1.9.9 instead of the datastax 1.9.2 - with limited query testing this still worked fine.  We'll put more effort into handling the cassandra dependencies, especially the conflicting ones, with later productization.
Comment 20 belong 2013-11-17 22:08:46 EST
Fixed before GA of major release - setting to requires_doc_text- accordingly
Comment 21 JBoss JIRA Server 2014-04-23 07:33:54 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2697 to Closed

Note You need to log in before you can comment on or make changes to this bug.