Bug 1018895 - Large blank are in the viewer and browser window
Large blank are in the viewer and browser window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
rawhide
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Christian Krause
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 11:56 EDT by Gayan Perera
Modified: 2013-11-10 03:08 EST (History)
2 users (show)

See Also:
Fixed In Version: gthumb-3.2.4-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 03:08:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
viewing mode. (45.38 KB, image/png)
2013-10-14 11:56 EDT, Gayan Perera
no flags Details
Added Image with marker (83.05 KB, image/png)
2013-10-15 12:18 EDT, Gayan Perera
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 708800 None None None Never

  None (edit)
Description Gayan Perera 2013-10-14 11:56:19 EDT
Created attachment 812094 [details]
viewing mode.

Description of problem:
A large blank area in the browsing window and in the viewer window is shown. This covers lot of area in the window which either the image list in browser mode or the image in viewer mode usual should use.


Version-Release number of selected component (if applicable):
3.2.3


How reproducible:
Every time

Steps to Reproduce:
1. Open a image in gthumb
2. Open gThumb in browser mode.

Actual results:
A large empty are in viewer mode window and the same large area in browser mode window.


Expected results:
The available window area must be used for viewing the image in view mode and available window area must be use to show the file in browser mode.


Additional info:
Attached a screenshot in view mode. The same large blank area will be there in browser mode as well.
Comment 1 Christian Krause 2013-10-14 15:45:20 EDT
I have looked at your screenshot, but actually I don't see an issue:

gthumb scales the picture with the correct aspect-ratio. In your case, gthumb has used the largest height which is possible. The height of the displayed picture can't be larger, otherwise it would not be completely visible.

If you would increase the height of your gthumb window, it would display the picture larger.

With respect to the browse mode, I have can't reproduce it. Please attach a screenshot for the browse mode, too.
Comment 2 Gayan Perera 2013-10-15 12:18:12 EDT
Created attachment 812623 [details]
Added Image with marker

The red line shows the full screen size,  The blue line shown the size of gThumb window which is maximized. The orange like marks the area which is empty which needs to be removed. The image which you can see in this screenshot is actually a screenshot of my screen which is 1366x768.
Comment 3 Christian Krause 2013-10-15 17:28:10 EDT
Ok, thanks for the description and the new picture.

I have just seen that there is a new gthumb release which is going to fix that problem.

Upstream bug report:
https://bugzilla.gnome.org/show_bug.cgi?id=708800

The problem happens only with gtk-3.10, so that explains why I couldn't reproduce it.

I'll update gthumb to that new release within the next days (or probably even earlier).
Comment 4 Fedora Update System 2013-10-18 19:45:27 EDT
gthumb-3.2.4-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/gthumb-3.2.4-1.fc20
Comment 5 Fedora Update System 2013-10-19 14:32:40 EDT
Package gthumb-3.2.4-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gthumb-3.2.4-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19523/gthumb-3.2.4-1.fc20
then log in and leave karma (feedback).
Comment 6 Gayan Perera 2013-10-20 12:55:36 EDT
The issue is fixed in 3.2.4-1.fc20
Comment 7 Fedora Update System 2013-11-10 03:08:47 EST
gthumb-3.2.4-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.