Bug 1018922 - Packstack configures nova/neutron for qpid username/password when none is required
Packstack configures nova/neutron for qpid username/password when none is req...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ivan Chavero
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 13:21 EDT by Steven Hardy
Modified: 2016-04-18 02:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.22.dev956
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:10:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Hardy 2013-10-14 13:21:09 EDT
Description of problem:
It seems recent versions of packstack (or probably the underlying puppet manifests) configure nova and neutron with a qpid username and password, but the broker is not configured to require one.

This breaks nova and neutron.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run packstack
2. Attempt to access nova/neutron
3. Observe they're broken, and that the config files contain a section like:

# Username for qpid connection
# qpid_username = ''
qpid_username = guest
# Password for qpid connection
# qpid_password = ''
qpid_password = guest


Actual results:
Nova/Neutron are misconfigured, the username/password thing seems to be a cut/paste error from rabbit somewhere.

Expected results:
Nova/Neutron are correctly configured.

Additional info:
Comment 1 Steven Hardy 2013-10-14 13:22:09 EDT
Observed with openstack-packstack-2013.2.1-0.10.dev763.fc20.noarch
Comment 2 Ivan Chavero 2014-01-16 21:51:43 EST
This problem does no appear in the latest package: openstack-packstack-2013.2.1-0.22.dev956

The qpid authentication is disabled in /etc/qpidd.conf so it will discard the credentials.

i can succesfully access nova and neutron

# nova image-list
+--------------------------------------+--------+--------+--------+
| ID                                   | Name   | Status | Server |
+--------------------------------------+--------+--------+--------+
| 73b952b2-08e5-4452-bba3-43d575a81354 | cirros | ACTIVE |        |
+--------------------------------------+--------+--------+--------+


# neutron agent-list
+--------------------------------------+--------------------+-----------------------+-------+----------------+
| id                                   | agent_type         | host                  | alive | admin_state_up |
+--------------------------------------+--------------------+-----------------------+-------+----------------+
| 01169f1f-3a44-4cb7-b22b-e534162f7228 | Open vSwitch agent | localhost.localdomain | :-)   | True           |
| c1766990-5ce1-478f-9c33-94b5e5f033ad | L3 agent           | localhost.localdomain | :-)   | True           |
| cd5c9a44-4da5-4c28-b008-3d6e89d8b16f | DHCP agent         | localhost.localdomain | :-)   | True           |
+--------------------------------------+--------------------+-----------------------+-------+----------------+

Note You need to log in before you can comment on or make changes to this bug.