Bug 1018993 - Mention distributed JTA transaction offered by jboss
Mention distributed JTA transaction offered by jboss
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: post-GA
: EAP 6.3.0
Assigned To: David Michael
Hayk Hovsepyan
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 17:39 EDT by Ondrej Chaloupka
Modified: 2014-11-23 18:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14875, Development Guide-6.2-1 Build Date: 02-10-2013 13:20:00 Topic ID: 4300-432593 [Latest]
Last Closed: 2014-11-23 18:17:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Chaloupka 2013-10-14 17:39:03 EDT
Title: About Java Transactions API (JTA)

There is a sentence "JTA transactions are not distributed across multiple application servers, and cannot be nested".

It would be fine to mention that the JTA api specification does not supports distributed transactions but JBoss supports such thing. In the way that distributed means that more EAP servers could be involved in one transaction.
Comment 3 Hayk Hovsepyan 2014-09-22 05:51:45 EDT
Because of https://bugzilla.redhat.com/show_bug.cgi?id=1018851 all changes are done in chapter "11.2.11. About Distributed Transactions" and it is phrased as:
"Java
Transaction Service (JTS) specification mandates that JTS transactions be able to be distributed
across application servers from different vendors (transaction distribution among servers from
different vendors is not a supported feature). Java Transaction API (JTA) does not define that but
JBoss EAP 6 supports distributed JTA transactions among JBoss EAP6 servers."

Verified on Revision 6.3.0-31

Note You need to log in before you can comment on or make changes to this bug.