Bug 101900 - [RFE] include support for *.vsd (ms-visio) or better exchange via *.dxf
[RFE] include support for *.vsd (ms-visio) or better exchange via *.dxf
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: dia (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 16:49 EDT by shrek-m
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-08 03:17:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shrek-m 2003-08-07 16:49:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Netscape/7.1

Description of problem:
could you include support for the *.vsd (ms-viso) format
and optimize the exchange via *.dxf ?

Version-Release number of selected component (if applicable):
dia-0.91-2.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. get an email-attachment *.vsd
2. save it
3. try it to open with
   dia, xfig, kivio, gimp, ...
4. install visio and save it as *.dxf for yourself
   because the windows-user
   do not know how to do this really great act
5. save it as *.jpg, *.ps

Actual Results:  no chance as *.vsd, *.dxf

as *.jpg and probably other formats you can open it with
gimp, nautilus, ...

ps2pdf works with *.ps

Expected Results:  dia should handle the ms-visio *.vsd, *.dxf
because the average windows-user has lost the ability to do
a simple  "save as"

i hope that this will not be the same with an average linux-user
in the near future.

Additional info:
Comment 1 Alexander Larsson 2003-08-08 03:17:27 EDT
The visio format is proprietary and secret, so we can't implement it.
Furthermore, this is very much not a packaging bug. If you want an actual
developer of dia to read this you should file a bug with the developers of dia
at http://bugzilla.gnome.org/

Note You need to log in before you can comment on or make changes to this bug.