Bug 1019020 - extremely slow console text scroll with vnc + qxl
extremely slow console text scroll with vnc + qxl
Status: CLOSED DUPLICATE of bug 1020393
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 21:13 EDT by Chris Murphy
Modified: 2013-12-02 14:15 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-02 14:15:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast showing problem (3.32 MB, video/webm)
2013-10-14 21:13 EDT, Chris Murphy
no flags Details
virsh dumpxml fedora20 (4.71 KB, text/plain)
2013-11-16 13:12 EST, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-14 21:13:01 EDT
Description of problem: Console text scrolls very slowly, increases boot times.


Version-Release number of selected component (if applicable):
virt-manager-0.10.0-4.git79196cdf.fc20.noarch
libvirt-1.1.3-2.fc20.x86_64
qemu-1.6.0-10.fc20.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Boot with rhgb quiet removed.
OR
2. hexdump -C /dev/vda1


Actual results:
Super slow. Lots of flickering. See screencast attachment.

Expected results:
In particular 2 should be very fast, I ought to get over 1-2MB of binary before I can hit command-C.



Additional info:
[root@f20s Videos]# ps -ef | grep qemu
qemu     13620     1 18 18:58 ?        00:02:19 /usr/bin/qemu-system-x86_64 -machine accel=kvm -name fedora20 -S -machine pc-i440fx-1.6,accel=kvm,usb=off -m 1536 -realtime mlock=off -smp 2,sockets=2,cores=1,threads=1 -uuid 8e370002-536b-47a1-90fd-732c90a0a599 -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/fedora20.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-kvm-pit-reinjection -no-hpet -no-shutdown -boot order=dc,menu=on -device ich9-usb-ehci1,id=usb,bus=pci.0,addr=0x5.0x7 -device ich9-usb-uhci1,masterbus=usb.0,firstport=0,bus=pci.0,multifunction=on,addr=0x5 -device ich9-usb-uhci2,masterbus=usb.0,firstport=2,bus=pci.0,addr=0x5.0x1 -device ich9-usb-uhci3,masterbus=usb.0,firstport=4,bus=pci.0,addr=0x5.0x2 -device ahci,id=ahci0,bus=pci.0,addr=0x8 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x6 -drive file=/var/lib/libvirt/images/Fedora-Live-Desktop-x86_64-20-Beta-TC2.iso,if=none,id=drive-ide0-0-0,readonly=on,format=raw -device ide-cd,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=/dev/guestvms/f20betatc2btrfs,if=none,id=drive-virtio-disk0,format=raw,cache=none,aio=native -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x9,drive=drive-virtio-disk0,id=virtio-disk0 -netdev tap,fd=24,id=hostnet0,vhost=on,vhostfd=25 -device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:04:42:1e,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=serial0 -vnc 0.0.0.0:0 -device qxl-vga,id=video0,ram_size=67108864,vram_size=67108864,bus=pci.0,addr=0x2 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
Comment 1 Chris Murphy 2013-10-14 21:13:49 EDT
Created attachment 812280 [details]
screencast showing problem
Comment 2 Cole Robinson 2013-11-09 19:12:09 EST
Please provide the guest config: sudo virsh dumpxml $vmname

Is this using the 'graphical' display, or over a text console ? (View->Text Console   will show you which)
Comment 3 Chris Murphy 2013-11-16 13:12:42 EST
Created attachment 824951 [details]
virsh dumpxml fedora20

This is via VNC using TigerVNC as the client.
Comment 4 Chris Murphy 2013-11-16 13:23:23 EST
Correction: also happens with virt-manager (in GNOME), with View > Text Console > Graphical Console VNC set.
Comment 5 Cole Robinson 2013-11-16 18:54:20 EST
qxl has had problems combined with qxl in the past. does switching to spice help? I realize it's not a full solution but it should help limit the problem at least.

Also try switch from qxl to cirrus but keeping VNC on
Comment 6 Chris Murphy 2013-11-25 18:08:15 EST
This may be a dup of bug 1020393.
Comment 7 Adam Williamson 2013-11-26 17:29:56 EST
Can you try it with the https://admin.fedoraproject.org/updates/xorg-x11-drv-qxl-0.1.1-3.fc20 update? Though I think that's mainly a spice-specific thing we're dealing with over there.
Comment 8 Cole Robinson 2013-12-02 14:15:39 EST
Marking as dup according to comment #6

*** This bug has been marked as a duplicate of bug 1020393 ***

Note You need to log in before you can comment on or make changes to this bug.