Bug 1019022 - constant failures reported in journal when run in qemu/kvm
constant failures reported in journal when run in qemu/kvm
Status: CLOSED DUPLICATE of bug 1018017
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-14 21:45 EDT by Chris Murphy
Modified: 2013-11-23 11:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 11:59:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journal -b -a (134.08 KB, text/plain)
2013-10-14 21:47 EDT, Chris Murphy
no flags Details

  None (edit)
Description Chris Murphy 2013-10-14 21:45:27 EDT
Description of problem: When running in qemu/kvm virtual machine, constant failures related to modemmanager. It also correlates (possibly causes) to avahi no longer working (unable to resolve mdns hostnames right when the modemmanager error occurs) even though it continues to run without errors.

Version-Release number of selected component (if applicable):
ModemManager-glib-1.1.0-2.git20130913.fc20.x86_64
ModemManager-1.1.0-2.git20130913.fc20.x86_64

How reproducible:
Always in qemu/kvm
Never on baremetal


Steps to Reproduce:
1. Install Live beta TC2 to a qemu/kvm VM
2. Reboot
3. Wait, then check the journal

Actual results:
Oct 14 19:34:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemMa
Oct 14 19:34:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.free
Oct 14 19:34:18 f20sv.localdomain dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Oct 14 19:34:18 f20sv.localdomain dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManag
Oct 14 19:36:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemMa
Oct 14 19:36:18 f20sv.localdomain dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Oct 14 19:36:18 f20sv.localdomain dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManag
Oct 14 19:36:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.free
Oct 14 19:38:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemMa
Oct 14 19:38:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.free
Oct 14 19:38:18 f20sv.localdomain dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Oct 14 19:38:18 f20sv.localdomain dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManag
Oct 14 19:40:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemMa
Oct 14 19:40:18 f20sv.localdomain dbus[600]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
Oct 14 19:40:18 f20sv.localdomain dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemManag
Oct 14 19:40:18 f20sv.localdomain dbus-daemon[600]: dbus[600]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.free
lines 1-51/51 (END)



Expected results:
Something similar to baremetal:

[root@f20s Videos]# journalctl -b | grep -i modem
Oct 14 10:56:11 f20s.localdomain systemd[1]: Starting Modem Manager...
Oct 14 10:56:14 f20s.localdomain ModemManager[353]: <info>  ModemManager (version 1.1.0-2.git20130913.fc20) starting...
Oct 14 10:56:14 f20s.localdomain systemd[1]: Started Modem Manager.
Oct 14 10:56:16 f20s.localdomain ModemManager[353]: <warn>  Couldn't find support for device at '/sys/devices/pci0000:00/0000:00:1c.5/0000:0c:00.0': not supported by any plugin
Oct 14 10:56:17 f20s.localdomain NetworkManager[424]: <info> ModemManager available in the bus


Additional info:
I also suspect that this is mucking up avahi because right at the time I get these messages, I can no longer ssh into the VM using its mdns hostname.
Comment 1 Chris Murphy 2013-10-14 21:47:45 EDT
Created attachment 812293 [details]
journal -b -a
Comment 2 Chris Murphy 2013-10-15 02:04:51 EDT
This bug is not related to loss of avahi/mdns. A system without ModemManager installed exhibits the same problem.
Comment 3 Michele Baldessari 2013-11-23 04:31:37 EST
This is the same as:
https://bugzilla.redhat.com/show_bug.cgi?id=1018017

There is an initial upstream patch at:
https://bugzilla.gnome.org/show_bug.cgi?id=703040

Please close this as duplicate of 1018017
Comment 4 Chris Murphy 2013-11-23 11:59:57 EST

*** This bug has been marked as a duplicate of bug 1018017 ***

Note You need to log in before you can comment on or make changes to this bug.