Bug 1019042 - xdrawchem included non-free files.
xdrawchem included non-free files.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xdrawchem (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2013-10-15 00:34 EDT by mejiko
Modified: 2015-02-12 08:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-12 08:58:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 39670 None None None Never

  None (edit)
Description mejiko 2013-10-15 00:34:01 EDT
Hello.

xdrawchem included non-free files. 
Please see GNU Savannah bug number "39670" datails.

I think that this package be affected by GNU Savannah bug number "39670".

Suggests:

1. Remove non-free files and rebuild.

2. Replace fedora free (fedora acceptable licensed) files.

3. Remove fedora repos.

Thanks.


Reference:


https://savannah.nongnu.org/bugs/?func=detailitem&item_id=39670
Comment 1 mejiko 2013-10-15 00:34:41 EDT
Blocking FE-Legal, This is license problem.
Comment 2 Dominik 'Rathann' Mierzejewski 2014-02-11 17:35:33 EST
I'm not sure where the BremserOneSphereHOSECodePredictor.java version which was the base for XDrawchem C++ code came from, but the oldest Java code version I can find was introduced in CDK in 2001 by Christoph Steinbeck himself and it was licensed under LGPLv2.1 already:

http://sourceforge.net/p/cdk/code/ci/13c5dc2f369399e67ca53424470bfea9f1cc4dd8/log/?path=/src/main/org/openscience/cdk/tools/BremserOneSphereHOSECodePredictor.java

http://sourceforge.net/p/cdk/code/ci/6faadfdd92c885490f4839ad26b4cde81d072079/
Comment 3 mejiko 2014-03-15 06:02:36 EDT
Changed to rawhide. 

Is this bug is resolved ?
How it this bug current status ?

Thanks.
Comment 4 Dominik 'Rathann' Mierzejewski 2014-05-19 14:51:04 EDT
I believe this can be closed as NOTABUG, but feel free to ping Tom Callaway about it.
Comment 5 Tom "spot" Callaway 2015-02-12 08:58:11 EST
You might want to have xdrawchem update their license attribution, since it seems it should be LGPL. Closing as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.