Bug 1019043 - kde-baseapps included non-free files.
Summary: kde-baseapps included non-free files.
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-baseapps (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-Legal
TreeView+ depends on / blocked
 
Reported: 2013-10-15 04:36 UTC by mejiko
Modified: 2014-11-24 15:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-24 15:55:18 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Savannah 39678 None None None Never
KDE Software Compilation 323427 None None None Never

Description mejiko 2013-10-15 04:36:32 UTC
Hello.

kde-baseapps included non-free files.
Please see GNU Savannah bug number "39678" datails.

I think that this package be affected by GNU Savannah bug number "39678".

Suggests:

1. Remove non-free files and rebuild.

2. Replace fedora free (fedora acceptable licensed) files.

3. Remove fedora repos.

Thanks.


Reference:


https://savannah.nongnu.org/bugs/?func=detailitem&item_id=39678

Comment 1 mejiko 2013-10-15 04:37:03 UTC
Blocking FE-Legal, This is license problem.

Comment 2 Rex Dieter 2013-10-15 13:02:22 UTC
To avoid having to click around for details:

bug #39678: kdebase: kdepasswd is possibly non-free

--------------------------------------------

Reported to KDE [1]. I'll give it some time before I put effort into repackaging. 
[1] https://bugs.kde.org/show_bug.cgi?id=323427

--------------------------------------------

In package kdebase, the file apps/kdepasswd/kdepasswd.cpp has a notice in the header with an X11 style license: 

...

But the "about" data in the code says that it falls under the (non-free) Artistic License:

    KAboutData aboutData("kdepasswd", 0, ki18n("KDE passwd"),
            KDE_VERSION_STRING, ki18n("Changes a UNIX password."),
            KAboutData::License_Artistic, ki18n("Copyright (c) 2000 Geert Jansen"));

Comment 3 mejiko 2014-03-15 10:10:35 UTC
Changed to rawhide.

How it this bug current status ? 
Is this bug is resolved ?

Thanks.

Comment 4 Kevin Kofler 2014-11-24 15:55:18 UTC
As per https://bugs.kde.org/show_bug.cgi?id=323427#c6 the author confirmed that the MIT license applies. (See e-mail attached to the upstream Bugzilla.)

The reason this was not changed in the KAboutData is probably that there is no KAboutData::License_MIT.


Note You need to log in before you can comment on or make changes to this bug.