Bug 1019069 - Messaging XSD is missing description of attributes
Messaging XSD is missing description of attributes
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: JMS (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: DR1
: EAP 6.3.0
Assigned To: Jeff Mesnil
Miroslav Novak
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 02:38 EDT by Miroslav Novak
Modified: 2014-06-29 18:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
In this release of JBoss EAP 6, the XML schema for the messaging subsystem is annotated with descriptions of the attributes and types. This enhancement is intended to help developers write the corresponding XML configuration.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:42:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2922 Major Resolved Add description to Messaging subsystem XML Schema 2014-07-28 08:20:00 EDT

  None (edit)
Description Miroslav Novak 2013-10-15 02:38:13 EDT
Description of problem:
Most of the elements in jboss-as-messaging_1_3.xsd is missing description. 

Expected results:
Elements should have description.
Comment 1 Jeff Mesnil 2013-10-17 03:41:43 EDT
The documentation reference for the messaging subsystem is the :read-resource-description management operation.

The XSD is purely informational and the elements are described only when they differ from the :read-resource-description model or if they are specific to the XSD schema
Comment 2 Miroslav Novak 2013-10-17 04:13:01 EDT
This is based on feedback from people who attended EAP 6 admin course. They complained about missing description of those attributes. Basically it was one of few sources from where they could get correct information. 

I agree with you that it's described in CLI. But this argument was denied because it's hard to find it. Also if EAP 6 server can't be started they could not get to this information. (There were some other complains about bad documentation we have for EAP 6).
Comment 3 Jeff Mesnil 2014-02-14 04:35:54 EST
PR for upstream https://github.com/wildfly/wildfly/pull/5911
Comment 5 Miroslav Novak 2014-02-26 04:28:39 EST
Thanks Jeff! I've checked jboss-as-messaging_1_4.xsd in EAP 6.3.0.DR1 and description for elements are there. 

Is it intentional to have it in jboss-as-messaging_1_4.xsd which was already released in EAP 6.2.0.GA and not to create new version jboss-as-messaging_1_5.xsd for EAP 6.3.0.x?
Comment 6 Jeff Mesnil 2014-02-26 04:36:43 EST
Yes, that's on purpose: I did not want to create a new 1.5 schema just to add documentation annotations.

if EAP 6.3 does not require any structural changes to its XML schema, 1.4 XSD will be used for it. Otherwise, a 1.5 schema with *structural* changes will be created from the 1.4 XSD and get the documentation annotations too.
Comment 7 Miroslav Novak 2014-02-26 06:22:19 EST
Ok, setting bz as verified.

Note You need to log in before you can comment on or make changes to this bug.