Bug 1019073 - Focus is getting removed from the target window
Focus is getting removed from the target window
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
20
Unspecified Unspecified
high Severity medium
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
RejectedFreezeException https://fedor...
: CommonBugs, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 02:51 EDT by Parag Nemade
Modified: 2014-03-12 04:05 EDT (History)
14 users (show)

See Also:
Fixed In Version: mutter-3.10.2-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-27 22:09:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log generated from "xinput test-xi2" command output (177.77 KB, text/plain)
2013-10-15 02:51 EDT, Parag Nemade
no flags Details
KDE Log generated from "xinput test-xi2" command output (45.20 KB, text/plain)
2013-10-15 02:52 EDT, Parag Nemade
no flags Details
MATE Log generated from "xinput test-xi2" command output (42.99 KB, text/plain)
2013-10-15 02:53 EDT, Parag Nemade
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 710296 None None None Never

  None (edit)
Description Parag Nemade 2013-10-15 02:51:01 EDT
Created attachment 812355 [details]
Log generated from "xinput test-xi2" command output

Description of problem:
I observed that On-Screen Keyboard (OSK) applications iok, eekboard, cellwriter, florence all stopped working/sending key events to focused application.

This looks like problem only in Gnome. I have successfully tested all above OSK applications in KDE, MATE. No issues.

Version-Release number of selected component (if applicable):


How reproducible:
always in gnome DE

Steps to Reproduce the bug:
1. start iok and click on any key
2. focused application will not display clicked key in iok UI

Test case for attached output:
1. start gnome-terminal
2. run iok
3. open another tab in gnome-terminal
4. run "xinput test-xi2"
5. focus this xinput window
6. try to click on any key in iok
7. close the xinput

Actual results:
In Gnome any OSK application fails to send keyevents/client fails to display key character

Expected results:
In Gnome any OSK application should send keyevents/client should display key character

Additional info:
Comment 1 Parag Nemade 2013-10-15 02:52:51 EDT
Created attachment 812356 [details]
KDE Log generated from "xinput test-xi2" command output
Comment 2 Parag Nemade 2013-10-15 02:53:30 EDT
Created attachment 812357 [details]
MATE Log generated from "xinput test-xi2" command output
Comment 3 Parag Nemade 2013-10-15 04:28:48 EDT
Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.14.3-4.fc20.x86_64
xorg-x11-server-Xorg-1.14.3-4.fc20.x86_64
xorg-x11-server-devel-1.14.3-4.fc20.x86_64
xorg-x11-server-utils-7.7-2.fc20.x86_64
Comment 4 Parag Nemade 2013-10-15 05:30:57 EDT
all those OSK apps worked fine on F19-updates system with
xorg-x11-server-Xorg-1.14.3-1.fc19.x86_64
Comment 5 Parag Nemade 2013-10-16 10:22:58 EDT
I also tried Fedora 20 Alpha and removed xorg-x11-server-common and xorg-x11-server-Xorg and installed initial 1.14.3-1 builds. But all those OSK applications still not working.
Comment 6 Parag Nemade 2013-10-16 10:59:05 EDT
I now used Fedora 19 system and updated directly following rpm
xorg-x11-server-common-1.14.3-4.fc20.x86_64
xorg-x11-server-Xorg-1.14.3-4.fc20.x86_64

I found that system is working fine, boot into gnome session and these OSK applications iok, eekboard worked fine.
Comment 7 Parag Nemade 2013-10-16 12:00:16 EDT
libXtst is not changed from f19 to f20, its same 1.2.2 version. Not sure then if something in gtk3 package creating this bug.

another thing caribou looks working fine which also uses libXtst library.
Comment 8 Matthias Clasen 2013-10-16 21:08:36 EDT
Works fine under metacity, which makes it unlikely that the X server is at fault.
Comment 10 Parag Nemade 2013-10-17 00:16:46 EDT
I can confirm that upstream developer submitted patch is working fine in Fedora 20 now. Waiting for upstream patch commit and Fedora build.
Comment 11 Mike Ruckman 2013-10-21 13:33:37 EDT
Discussed this in 2013-10-21 Blocker Review Meeting [1]. Rejected as a freeze exception bug, as it does not seem to affect GNOME's own OSK, and others would have to be installed from repositories anyway so this can be fixed with an update.

[1] http://meetbot.fedoraproject.org/fedora-blocker-review/2013-10-21/
Comment 12 Parag Nemade 2013-11-16 01:49:02 EST
please fix this before F20 Final freeze otherwise, onscreen keyboard applications will remain non-functional.
Comment 13 Adam Williamson 2013-11-16 02:07:34 EST
as per c#11, it really doesn't have much relation to freezes; no OSK but GNOME's is installed by default, so any other is always going to come from the repositories. This can be fixed with an update as well as before freeze.
Comment 14 Parag Nemade 2013-12-04 10:26:37 EST
I confirm this bug is not fixed in latest Fedora 20 Final TC4 release. Therefore, I request to add this bug on https://fedoraproject.org/wiki/Common_F20_bugs
Comment 15 Parag Nemade 2013-12-10 07:30:41 EST
Whoever is responsible for pushing new mutter updates, please include fix from https://bugzilla.gnome.org/show_bug.cgi?id=710296 which will fix this bug in F20.
Comment 16 Fedora Update System 2013-12-10 17:22:42 EST
mutter-3.10.2-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mutter-3.10.2-4.fc20
Comment 17 Fedora Update System 2013-12-11 11:46:35 EST
Package mutter-3.10.2-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mutter-3.10.2-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23182/mutter-3.10.2-4.fc20
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-12-19 21:04:13 EST
mutter-3.10.2-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 19 Eugene Grybinnyk 2013-12-23 13:03:37 EST
It looks like this fix is breaking something else.

"... Downgrading to mutter-3.10.2-2.fc20.x86_64 seems to have stopped the crashes." from https://bugzilla.redhat.com/show_bug.cgi?id=995785#c34
Comment 20 Adam Williamson 2013-12-23 15:57:10 EST
Yes. That bug seems more significant than this one, so I'm sending out a 3.10.2-5 update which simply reverts the 3.10.2-4 change (which was to add the patch for this bug). We can do a -6 with both this and #995785 fixed once the patches for #995785 are reviewed.
Comment 21 Adam Williamson 2013-12-23 16:21:58 EST
https://admin.fedoraproject.org/updates/mutter-3.10.2-5.fc20 will re-introduce this bug, that is expected and intended. I'll try to do a scratch build with the fixes for both this and #995785, but I'm not comfortable sending it to updates-testing without upstream review.
Comment 22 Adam Williamson 2013-12-23 16:35:45 EST
http://koji.fedoraproject.org/koji/taskinfo?taskID=6330186 is a scratch build which includes both the fix for this bug and the current upstream patches for #995785, if people want to test that.
Comment 23 Adam Williamson 2013-12-27 22:09:28 EST
OK, -6 reinstated the fix for this, and has gone stable, so closing again.
Comment 24 Maciek Borzecki 2013-12-29 04:29:23 EST
I'm not sure if it's fixed. Focusing still does not work properly. For instance, when I start SC2 through wine, the wine window is not made toplevel and it does not have focus. Switching focus with alt-tab sort of works, but the in game keys don't work. It did work well with mutter-3.10.2-2.fc20.
Comment 25 Adam Williamson 2013-12-29 11:49:37 EST
This bug is about on-screen keyboards, not about games in wine.
Comment 26 Maciek Borzecki 2014-02-05 04:27:20 EST
I've bisected mutter 3.10 branch, commit https://git.gnome.org/browse/mutter/commit/?h=gnome-3-10&id=844f4e9348e29be52ded19d83fdbd1e5e9ce5529 that fixed this report also broke https://bugzilla.redhat.com/show_bug.cgi?id=1047407

Note You need to log in before you can comment on or make changes to this bug.