Bug 1019126 - RFE : enable Eliptic Curve algorithm in libgcrypt
RFE : enable Eliptic Curve algorithm in libgcrypt
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libgcrypt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ecc
  Show dependency treegraph
 
Reported: 2013-10-15 04:08 EDT by Xavier Bachelot
Modified: 2013-11-10 01:59 EST (History)
4 users (show)

See Also:
Fixed In Version: libgcrypt-1.5.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-06 22:40:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xavier Bachelot 2013-10-15 04:08:18 EDT
Description of problem:
Until very recently, Eliptic Curse cryptography was banned from Fedora because it is/was legally encumbered, and thus support for it carefully removed from libgcrypt and other sofware. However, the restriction has been lifted for openssl, which is now shipping with ECC enabled, thus my understanding is libgcrypt can use it as well.

Version-Release number of selected component (if applicable):
libgcrypt-1.5.3-1.fc20
libgcrypt-1.5.3-1.fc19
libgcrypt-1.5.3-1.fc18

Additional info:
Relevant openssl bug : https://bugzilla.redhat.com/show_bug.cgi?id=319901
Comment 1 Fedora Update System 2013-10-21 17:38:15 EDT
libgcrypt-1.5.3-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libgcrypt-1.5.3-2.fc19
Comment 2 Fedora Update System 2013-10-21 17:38:25 EDT
libgcrypt-1.5.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libgcrypt-1.5.3-2.fc20
Comment 3 Fedora Update System 2013-10-22 14:53:58 EDT
Package libgcrypt-1.5.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libgcrypt-1.5.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19700/libgcrypt-1.5.3-2.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-11-06 22:40:35 EST
libgcrypt-1.5.3-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-11-10 01:59:41 EST
libgcrypt-1.5.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.