Bug 101915 - oops stack backtrace useless
oops stack backtrace useless
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
2.1
ia64 Linux
medium Severity low
: ---
: ---
Assigned To: Don Howard
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-07 20:02 EDT by Eric Schwartz
Modified: 2007-11-30 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 14:01:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Schwartz 2003-08-07 20:02:34 EDT
Description of problem:
As of Q2, when an oops happens, the backtrace is only one level deep, and
just looks like:

Call Trace: [<e0000000044148b0>] sp=0xe000004045b279f0 bsp=0xe000004045b20f68
decoded to show_stack [kernel] 0x50


Version-Release number of selected component (if applicable):
kernel-2.4.18-e.31

How reproducible:
100%

Steps to Reproduce:
1. do something to cause an oops
2. note lack of backtrace info
    
Actual results:
only one line of backtrace info is printed, and that line is pretty useless.

Expected results:
full stack trace is printed.

Additional info:
The one line we do get is shortly thereafter followed by a panic().  I'm not
sure, but I believe the aborted backtrace may be caused by the recent change to
force an oops to always panic(), causing the panic to interrupt show_stack(),
and causing the machine to reboot.  This is just a theory, and is welcome to be
tossed out if you like.
Comment 1 Arjan van de Ven 2003-08-08 04:14:02 EDT
we most likely fixed this already, please check a more current kernel
Comment 2 Eric Schwartz 2003-08-08 13:01:33 EDT
Are there any more recent kernels for the 2.1 series? e.31 is the latest we have.
Comment 3 Jason Baron 2003-11-10 17:10:50 EST
The latest is e.38, although i'm not sure if this issue is addressed
there...i'm looking into it...any additional information is more than
welcomed.
Comment 4 Eric Schwartz 2003-11-10 17:23:46 EST
Can you send me a copy of this kernel?  I don't have any kernels more
recent that e.31.  Alternatively, you should be able to verify this
easily on any ia64 box; as I said, just force an oops() and see what
you get for a stack trace.
Comment 5 Jason Baron 2004-09-08 17:00:52 EDT
The latest rhel2.1 ia64 kernel is U5, e.47 found at:

http://people.redhat.com/~jbaron/.private/u5/2.4.18-e.47/
Comment 6 Ernie Petrides 2005-09-12 15:47:55 EDT
Correcting product version.
Comment 7 Don Howard 2005-09-16 14:01:15 EDT
This is a very old report.  sysrq-c appears to generate correct backtrace info
on current derry kernels.

If this issue is still seen on current kernels, please reopen this bug and add
specific steps to reproduce.



Note You need to log in before you can comment on or make changes to this bug.