Bug 1019152 - thermostat doesn't start
thermostat doesn't start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thermostat (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Severin Gehwolf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 04:41 EDT by Marcela Mašláňová
Modified: 2013-10-27 01:34 EDT (History)
5 users (show)

See Also:
Fixed In Version: thermostat-0.9.2-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-27 01:34:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcela Mašláňová 2013-10-15 04:41:30 EDT
Description of problem:
I executed modified commands according to http://icedtea.classpath.org/wiki/Thermostat/UserGuide

As user:
/usr/bin/thermostat storage --start
/usr/bin/thermostat agent -d mongodb://127.0.0.1:27518
which fails, details in attachment.

Version-Release number of selected component (if applicable):
rpm -q thermostat mongodb
thermostat-0.9.2-4.fc19.x86_64
mongodb-2.4.6-1.fc19.x86_64


How reproducible:
Every time.

Expected results:
It should run by start automatically, no further configuration should be needed.
Comment 1 Severin Gehwolf 2013-10-15 06:09:28 EDT
Thanks for the bug report Marcela.

This issue is caused by an IndexOutOfBoundsException thrown when we parse "mongod --version" output (in turn caused by the mongodb update from 2.2.x to 2.4.x which changed the output format of "mongod --version"). "thermostat storage" uses this internally in order to fire up mongod with appropriate - and supported - flags.

Fix went in weeks ago upstream[1]. F20 and better will get a newer thermostat version, so they should not be affected by this. A F19 update will be available shortly.

[1] http://icedtea.classpath.org/hg/thermostat/rev/4279c0994a38
Comment 2 Fedora Update System 2013-10-15 06:12:55 EDT
thermostat-0.9.2-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/thermostat-0.9.2-5.fc19
Comment 3 Marcela Mašláňová 2013-10-17 05:57:50 EDT
Gui seems to be working but if I add http://127.0.0.1:27518/ in firefox, I see:

You are trying to access MongoDB on the native driver port. For http diagnostic access, add 1000 to the port number

I've added 1000 and nothing happened.

systemctl  status mongod
mongod.service - High-performance, schema-free document-oriented database
   Loaded: loaded (/usr/lib/systemd/system/mongod.service; disabled)
   Active: active (running) since Thu 2013-10-17 11:48:11 CEST; 9min ago

I have no JVM running.
Comment 4 Severin Gehwolf 2013-10-17 06:24:47 EDT
(In reply to Marcela Mašláňová from comment #3)
> Gui seems to be working but if I add http://127.0.0.1:27518/ in firefox, I
> see:
> 
> You are trying to access MongoDB on the native driver port. For http
> diagnostic access, add 1000 to the port number
> 
> I've added 1000 and nothing happened.
> 
> systemctl  status mongod
> mongod.service - High-performance, schema-free document-oriented database
>    Loaded: loaded (/usr/lib/systemd/system/mongod.service; disabled)
>    Active: active (running) since Thu 2013-10-17 11:48:11 CEST; 9min ago
> 
> I have no JVM running.

What are you trying to do? We deliberately disable the mondodb http interface (--nohttpinterface option in ps ax | grep mongod output). See http://docs.mongodb.org/manual/reference/program/mongod/#bin.mongod

If you want to use thermostat's WebStorage backend (over mongodb), this will require some setup. Something along the lines of:
https://fedoraproject.org/wiki/QA:Testcase_thermostat_web_basic

Please note that this (WebStorage) has changed quite a bit and we'll have to update docs for latest thermostat which will get into F20 and up. It was a tech-preview for F19. Using Web storage and thermostat is part of a larger effort to secure Thermostat. See http://icedtea.classpath.org/wiki/Thermostat/SecurityConsiderations

I suggest to work through test cases up to web_basic here in order to get a basic idea about thermostat:
https://fedoraproject.org/wiki/Test_Day:2013-05-23_Thermostat

Does this help?
Comment 5 Marcela Mašláňová 2013-10-17 06:50:39 EDT
Ok, I'll go through Test Day, when I have more time. You can close it now.
Comment 6 Fedora Update System 2013-10-18 15:51:22 EDT
Package thermostat-0.9.2-5.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing thermostat-0.9.2-5.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19328/thermostat-0.9.2-5.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-10-27 01:34:01 EDT
thermostat-0.9.2-5.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.