Bug 1019156 - Missing input constraints for Pool sizes on Datasource setup screen
Missing input constraints for Pool sizes on Datasource setup screen
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER7
: EAP 6.2.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 04:43 EDT by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:16:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-15 04:43:54 EDT
Description of problem:
 There should be numeric input validation for min and max pool size input fields on Datasource setup screen. User can add string as pool size now -> post-install configuration will fail.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER5

How reproducible:
 Always

Steps to Reproduce:
 1. Start gui installer, use default values until you get into Post-Install Configuration screen.
 2. Select to Install JDBC driver and Datasource
 3. On Datasource setup screen enter "foo" as Min pool size and "bar" as Max pool size.
 4. Finish the installation

Actual results:
 Post-install configuration will fail, installation ends with failure message.

Expected results:
 Error dialo will appear once user push Next button on Datasource screen.

Additional info:
 It would be nice to have CLI operation results in post-install logs, so user could easily spot the cause of post-install configuration failure without manually reproducing all configuration steps. I'll create another BZ for this.
Comment 1 Petr Kremensky 2013-10-15 06:15:54 EDT
I am also able to enter empty Connection Url -> post-install configuration will fail as well.
Comment 2 Petr Kremensky 2013-10-15 07:42:53 EDT
And empty pool sizes.
Comment 3 Petr Kremensky 2013-10-15 08:31:35 EDT
I'll make a little summary here as this starts to be a little confusing.
Datasource Setup screen:
-- missing numeric validation:
- Min pool size 
- Max pool size
- min pool size can be greater than max pool size now!

-- missing empty validation
- Min pool size 
- Max pool size
- Security domain
- Username
- Password
- Connection URL

-- JNDI validation 
- JNDI name
- covered by BZ1019241
Comment 5 Petr Kremensky 2013-10-18 06:22:35 EDT
I can still enter empty Recovery user and Recovery password -> post-installation fail. Also Values for default XA Properties can be empty.
Comment 6 Petr Kremensky 2013-10-18 08:08:14 EDT
Can you please also update pools input fields to accept only numeric values like it's on custom port input fields?
Comment 7 Miles Tjandrawidjaja 2013-10-18 14:30:23 EDT
Hello,

I have fixed validation for the User/Password fields I missed.
The XA Property validations are back.
Also updated fields for min/max pools so that you can only type in numeric values.
Comment 8 Petr Kremensky 2013-11-01 09:47:07 EDT
Verified on EAP 6.2.0.ER7 installer.

Note You need to log in before you can comment on or make changes to this bug.