Bug 1019167 - [api] hy_query_filter_latest filters arch as well as NEVR
[api] hy_query_filter_latest filters arch as well as NEVR
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: hawkey (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Honza Silhan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 05:00 EDT by Richard Hughes
Modified: 2013-11-16 02:11 EST (History)
2 users (show)

See Also:
Fixed In Version: dnf-0.4.7-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-16 02:11:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Hughes 2013-10-15 05:00:01 EDT
Description of problem:

installed:
glibc-2.17-4.fc19.x86_64
available:
glibc-2.16-24.fc18.x86_64
glibc-2.16-24.fc18.i686

When not using hy_query_filter_latest a HY_EQ HY_PKG_NAME glibc correctly returns:

glibc-2.17-4.fc19.x86_64
glibc-2.16-24.fc18.x86_64
glibc-2.16-24.fc18.i686

When using hy_query_filter_latest the same query returns:

glibc-2.17-4.fc19.x86_64
glibc-2.16-24.fc18.i686

I'm guessing you don't want the arch in the version comparison there. PackageKit uses the "newest" filter quite a bit, and does expect multiarch packages. Thanks.

Version-Release number of selected component (if applicable): hawkey-0.4.2-1.git4c51f65.fc20.x86_64
Comment 1 Ales Kozumplik 2013-10-15 08:24:26 EDT
After a discussion: what is needed here is an API to filter both kinds of latest packages, that is per-arch and absolutely latest. Low prio for now.
Comment 2 Honza Silhan 2013-11-04 16:20:12 EST
Fixed in hawkey-0.4.5
Comment 3 Fedora Update System 2013-11-11 08:47:31 EST
dnf-0.4.7-1.fc20, hawkey-0.4.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/hawkey-0.4.5-1.fc20,dnf-0.4.7-1.fc20
Comment 4 Fedora Update System 2013-11-11 19:40:49 EST
Package dnf-0.4.7-1.fc20, hawkey-0.4.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.7-1.fc20 hawkey-0.4.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-21117/hawkey-0.4.5-1.fc20,dnf-0.4.7-1.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-16 02:11:28 EST
dnf-0.4.7-1.fc20, hawkey-0.4.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.