This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019190 - Some issues for openshift.sh instllation script.
Some issues for openshift.sh instllation script.
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
2.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 05:27 EDT by Johnny Liu
Modified: 2017-03-08 12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 04:11:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johnny Liu 2013-10-15 05:27:53 EDT
Description of problem:
wget https://raw.github.com/openshift/openshift-extras/enterprise-2.0/enterprise/install-scripts/generic/openshift.sh

Review the code, found the following issues:
1. miss  "|| abort_install" for line 733, and using an incorrect repo name for rhscl channel in line 734.
 731   if need_rhscl_repo
 732   then
 733     rhn-channel --add --channel rhscl-1-x86_64-server-6-rpm --user ${CONF_RHN_REG_NAME} --password ${CONF_RHN_REG_PASS}
 734     echo -e "[jb-ews-2-x86_64-server-6-rpm]\npriority=3\n" >> $RHNPLUGINCONF
 735   fi

2. miss "--save" option for 809 line, and did not set priority for rhscl channel.
 813    if need_rhscl_repo
 814    then
 815      yum-config-manager --enable rhscl-1-for-rhel-6-server-rpms
 816    fi


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Brenton Leanhardt 2013-11-05 14:19:30 EST
It looks like the yum configuration code has been refactored recently and that these problems have been addressed.
Comment 3 Johnny Liu 2013-11-07 01:37:16 EST
Verified this bug the latest installation script, it is indeed refactored, and the above issue is fixed now.

Note You need to log in before you can comment on or make changes to this bug.