Bug 1019209 - Horizon: The metering UI doesn't work due to python-ceilometerclient outdated version.
Horizon: The metering UI doesn't work due to python-ceilometerclient outdated...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
4.0
Unspecified Linux
high Severity high
: beta
: 4.0
Assigned To: Matthias Runge
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 05:53 EDT by Nir Magnezi
Modified: 2013-12-19 19:27 EST (History)
7 users (show)

See Also:
Fixed In Version: python-django-horizon-2013.2-0.15.rc2.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:27:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Horizon Error (Debug Mode) (29.52 KB, text/x-log)
2013-10-15 05:53 EDT, Nir Magnezi
no flags Details
httpd errors (DEBUG Mode) (6.93 KB, text/x-log)
2013-10-15 05:54 EDT, Nir Magnezi
no flags Details

  None (edit)
Description Nir Magnezi 2013-10-15 05:53:21 EDT
Created attachment 812411 [details]
Horizon Error (Debug Mode)

Description of problem:
=======================
The metering UI doesn't work when I navigate to it.
Direct link would bee: http://<FQDN>/dashboard/admin/metering/

IRC:
<jpichon> nmagnezi: ... but yes it's a version issue, the "period" parameter was added in 1.0.1

Version-Release number of selected component (if applicable):
=============================================================
RHOS 4.0 Puddle 2013-10-03.3

python-ceilometerclient-1.0.0-2.el6ost.noarch
python-django-horizon-2013.2-0.13b3.el6ost.noarch

How reproducible:
=================
Always.

Steps to Reproduce:
===================
1. Install OpenStack Via packstack
2. Browse to http://<FQDN>/dashboard/admin/metering/

Actual results:
===============
Horizon "something went wrong" error page.

Expected results:
=================
Metering UI
Comment 1 Nir Magnezi 2013-10-15 05:54:12 EDT
Created attachment 812412 [details]
httpd errors (DEBUG Mode)
Comment 2 Nir Magnezi 2013-10-15 06:01:27 EDT
Taken from IRC Chat:

<mrunge> nmagnezi, horizon-2013.rc2 is currently building, including the fix
Comment 3 Matthias Runge 2013-10-15 06:03:14 EDT
the requirement for python-ceilometerclient >= 1.0.6 is included in 
python-django-horizon-2013.2-0.15.rc2.el6ost
Comment 5 Nir Magnezi 2013-10-16 06:56:27 EDT
Verified NVR: python-django-horizon-2013.2-0.15.rc2.el6ost.noarch

1. The python-ceilometerclient version is now 1.0.6-1
2. Verified that the metering UI is avalible via: http://<FQDN>/dashboard/admin/metering/
Comment 8 errata-xmlrpc 2013-12-19 19:27:52 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.