Bug 101921 - kernel results in segmentation fault when compiling or running configure
kernel results in segmentation fault when compiling or running configure
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-08 00:29 EDT by Sam Gill
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-12 01:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
says kernel bug at line 158 fault.c (2.89 KB, text/plain)
2003-08-11 00:47 EDT, Sam Gill
no flags Details
looked at the fault.c and realized that I didn't give enough info (202.05 KB, text/plain)
2003-08-11 00:58 EDT, Sam Gill
no flags Details

  None (edit)
Description Sam Gill 2003-08-08 00:29:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
When installing or compiling programs with such options as "configure", "make",
"make install" or "gcc x -o x", I get segmentation faults. I would have just
said it was gcc, but make is powered by perl, so I don't know which is having
the problem. I have tried running simple programs and complex ones. I sometimes
get the segmentation fault very randomly. I recieved it once when rebooting and
the if-cfg script generated a segmentation fault, the network card did not come
up. However when I logged in I started /etc/init.d/network and it faulted, and I
did it once more and it worked just fine. Even while using the uptime command it
is random. I wasn't really bothered until when trying to compile apache I
couldn't even get through the configure script without it faulting. I was able
to get through the configure script of openssl, but could not run the makefile
with any success. 

Version-Release number of selected component (if applicable):
kernel-2.4.21-1.1931.2.349.2.2.ent

How reproducible:
Sometimes

Steps to Reproduce:
1.Works everytime I try to configure httpd-2.0.46
2. unzip and cd
3. ./configure (randomly get segmentation faults, at different points.)
4. I have not reinstalled the AS edition
5. in other situations (running uptime, it is completly random)    

Actual Results:  sometime it works and sometimes it stops with segmentation
faults all the way.

Expected Results:  I would expect to never get a seg fault from a binary like
uptime, I usually don't have problems with configure either.

Additional info:

system dose not crash. no cores are dumped.
sometimes outputs message (from configure script) that C compiler could not
create executables, but this is false, because I have created c and c++
executables on this same box, before and after this error message.
Comment 1 Arjan van de Ven 2003-08-08 04:19:12 EDT
is there anything usefull in dmesg or the logs ?
Comment 2 Sam Gill 2003-08-11 00:47:33 EDT
Created attachment 93561 [details]
says kernel bug at line 158 fault.c

output of /var/log/messages

sorry I didn't send this sooner, was checking email, not bugzilla.
never did this before, getting used to it :)
thanks,
 -sam
Comment 3 Sam Gill 2003-08-11 00:58:23 EDT
Created attachment 93562 [details]
looked at the fault.c and realized that I didn't give enough info

looking at the fault.c code, it writes a printk() messages,
this messgage is exactly the same for all instances when it appears to crash.

keeps saying that "invalid kernel-mode pagefault 0! [addr:00000000,
eip:021389ef]"

I included the whole messages file for you, active since the computer has been
up for now 5 days. 

thanks,
 -sam.

ps happy to provide any more information that you request.
Comment 4 Arjan van de Ven 2003-08-11 09:03:18 EDT
this looks like the fingerprint of a crash we already fixed; a fixed kernel is
available for the RHEL beta via RHN

Note You need to log in before you can comment on or make changes to this bug.