Bug 1019216 - Re-enable elliptic curve cryptography (ecc) in nss-softokn
Re-enable elliptic curve cryptography (ecc) in nss-softokn
Status: CLOSED DUPLICATE of bug 1019244
Product: Fedora
Classification: Fedora
Component: nss-softokn (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ecc
  Show dependency treegraph
 
Reported: 2013-10-15 06:06 EDT by Scott Schmit
Modified: 2013-11-23 20:41 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1019222 (view as bug list)
Environment:
Last Closed: 2013-11-23 20:41:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to nss-softokn to re-enable ECC (3.68 KB, patch)
2013-10-17 09:05 EDT, Scott Schmit
no flags Details | Diff

  None (edit)
Description Scott Schmit 2013-10-15 06:06:02 EDT
Description of problem:
The current version of the nss-softokn package does not support elliptic curve cryptography algorithms. Support is available upstream.

Version-Release number of selected component (if applicable):
nss-softokn-3.15.2-1.fc19.x86_64

How reproducible:
100%

Steps to Reproduce:
1. grep mozilla-crypto-strip.sh nss-softokn.spec

Actual results:
ECC is stripped out of the nss-softokn package

Expected results:
ECC is not stripped out of the nss-softokn package

Additional info:
openssl has now been allowed to re-enable ECC: Bug 319901
I don't mean to exclude other versions of Fedora, but F19 is what I use, and I'm not sure of the nss version in F18, etc.
Comment 1 Scott Schmit 2013-10-17 09:05:55 EDT
Created attachment 813319 [details]
Patch to nss-softokn to re-enable ECC

I wasn't sure if patches should include changelog/release/sources changes or not, so I included them.  Of course, you'll need to adjust accordingly.
Comment 2 Elio Maldonado Batiz 2013-11-23 20:41:21 EST

*** This bug has been marked as a duplicate of bug 1019244 ***

Note You need to log in before you can comment on or make changes to this bug.