Bug 1019219 - PassEnv warning messages are shown when deploy php app
PassEnv warning messages are shown when deploy php app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Jakub Hadvig
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 06:14 EDT by Ma xiaoqiang
Modified: 2016-07-03 20:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-26 14:08:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-10-15 06:14:16 EDT
Description of problem:
Warning messages are shown when deploy php app

Version-Release number of selected component (if applicable):
devenv_3898

How reproducible:
always

Steps to Reproduce:
1.create a php app;
#rhc app create phpapp php 
2.do some changes on this app
3.deploy the app
#git commit -a -m 'test' && git push

Actual results:
Output:
remote: [Tue Oct 15 05:42:15 2013] [warn] PassEnv variable SHELL was undefined
remote: [Tue Oct 15 05:42:15 2013] [warn] PassEnv variable USER was undefined
remote: [Tue Oct 15 05:42:15 2013] [warn] PassEnv variable LOGNAME was undefined

ssh into app gear, we can find these envs

Expected results:
Shouldn't  show  any warning message

Additional info:
similar problem on python,perl,ruby.
Comment 1 Michal Fojtik 2013-10-30 11:58:59 EDT
I can see these messages also for other cartridges. I thought this just happen on devenv and it is due to some verbose settings is enabled there.
Comment 2 Michal Fojtik 2013-10-31 09:41:38 EDT
The PR is here:

https://github.com/openshift/origin-server/pull/4061
Comment 3 openshift-github-bot 2013-10-31 11:31:45 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/1cea46b79ff1c844b984fab451149c325e1a7c54
Bug 1019219 - Exclude USER,SHELL and LOGNAME from passenv.conf
Comment 4 Ma xiaoqiang 2013-11-01 01:01:59 EDT
check it on devenv_3979
1.create a php app
#rhc app create phpapp php-5.3 --server ec2-184-73-149-206.compute-1.amazonaws.com
2.do some change, then git push 

Output:
remote: Stopping PHP cartridge
remote: [Fri Nov 01 00:56:06 2013] [warn] PassEnv variable SHELL was undefined
remote: [Fri Nov 01 00:56:06 2013] [warn] PassEnv variable USER was undefined
remote: [Fri Nov 01 00:56:06 2013] [warn] PassEnv variable LOGNAME was undefined
remote: Waiting for stop to finish
remote: Building git ref 'master', commit 3cdd2eb
remote: Building PHP cartridge
remote: Preparing build for deployment
remote: Deployment id is 88d9aac8
remote: Activating deployment
remote: Starting PHP cartridge
remote: Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://527333ee87fe11c9f6000032@phpapp-xia.dev.rhcloud.com/~/git/phpapp.git/
   b1be18f..3cdd2eb  master -> master
Comment 5 Michal Fojtik 2013-11-06 17:59:38 EST
Hmm I cannot reproduce this on my devenv... Moving to Vojtech for detailed investigation, since I saw other undefined variables in other cartridge as well (some SELINUX env vars as well) and he is the original author of passenv.conf.
Comment 6 openshift-github-bot 2014-02-11 12:15:28 EST
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/b1daeb55c51caf618021d7769434f02cb2ec90eb
Bug 1019219 - PassEnv warning messages are shown when deploy app
Comment 7 Ma xiaoqiang 2014-02-11 20:55:18 EST
check on devevn_4363
1.create a php app
2.do some change, then git push
Output:
Counting objects: 7, done.
Compressing objects: 100% (4/4), done.
Writing objects: 100% (4/4), 372 bytes, done.
Total 4 (delta 2), reused 0 (delta 0)
remote: Stopping PHP 5.3 cartridge (Apache+mod_php)
remote: Waiting for stop to finish
remote: Building git ref 'master', commit 4f4e8ee
remote: Checking deplist.txt for PEAR dependency..
remote: Preparing build for deployment
remote: Deployment id is 8c0d8399
remote: Activating deployment
remote: Starting PHP 5.3 cartridge (Apache+mod_php)
remote: -------------------------
remote: Git Post-Receive Result: success
remote: Activation status: success
remote: Deployment completed with status: success
To ssh://52fad1d3333a342d11000001@phpapp-xiaom.dev.rhcloud.com/~/git/phpapp.git/
   445cfb6..4f4e8ee  master -> master

Note You need to log in before you can comment on or make changes to this bug.