Bug 1019261 - cups-filters-1.0.39-1.fc19.x86_64: bad printing of gray color
cups-filters-1.0.39-1.fc19.x86_64: bad printing of gray color
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cups-filters (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 07:30 EDT by Joachim Backes
Modified: 2013-11-10 01:38 EST (History)
3 users (show)

See Also:
Fixed In Version: cups-filters-1.0.40-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:38:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
LO document with wrong printed table line background (is light gray!) (17.64 KB, application/vnd.oasis.opendocument.text)
2013-10-15 09:48 EDT, Joachim Backes
no flags Details
Good printout (13.69 KB, text/x-log)
2013-10-16 00:18 EDT, Joachim Backes
no flags Details
Bad printout (12.02 KB, text/x-log)
2013-10-16 00:20 EDT, Joachim Backes
no flags Details

  None (edit)
Description Joachim Backes 2013-10-15 07:30:50 EDT
Description of problem:

After updating to 

cups-filters-libs-1.0.39-1.fc19.x86_64
cups-filters-1.0.39-1.fc19.x86_64

the gray background of LibreOffice documents is printed bad: 

I use some Libreoffice documents with gray background.
I'm printing to a Samsung ML-1660 B/W printer. Since that cups-filter version
update, the gray parts of my document are signifinatly darker printed
than with the elder version, and the gray areas are not smoothly
printed.

No problems with  cups-filters.x86_64 0:1.0.38-2.fc19, 
  cups-filters-libs.x86_64 0:1.0.38-2.fc19 and ghostscript-cups.x86_64 0:9.07-15.fc19

Version-Release number of selected component (if applicable):
cups-filters-libs-1.0.39-1.fc19.x86_64
cups-filters-1.0.39-1.fc19.x86_64

How reproducible:
always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Jiri Popelka 2013-10-15 07:44:04 EDT
That's strange because upstream 1.0.39 only added 2 of Tim's patches that we already had in Fedora's 1.0.38. So nothing changed AFAICT in other words.
Comment 3 Tim Waugh 2013-10-15 09:20:26 EDT
Could you please try cups-filters-1.0.40-2.0.0.1.fc19?

https://koji.fedoraproject.org/koji/taskinfo?taskID=6061940

The x86_64 packages are here:
https://koji.fedoraproject.org/koji/taskinfo?taskID=6061954

I suspect the fixes for format string mismatches broke something. Those fixes went into cups-filters-1.0.38-3.fc19, so just after the "working" packages you tried.
Comment 4 Joachim Backes 2013-10-15 09:37:00 EDT
(In reply to Tim Waugh from comment #3)
> Could you please try cups-filters-1.0.40-2.0.0.1.fc19?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=6061940
> 
> The x86_64 packages are here:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=6061954
> 
> I suspect the fixes for format string mismatches broke something. Those
> fixes went into cups-filters-1.0.38-3.fc19, so just after the "working"
> packages you tried.

I'm sorry, but same problems with 

cups-filters-libs-1.0.40-2.0.0.1.fc19.x86_64
cups-filters-1.0.40-2.0.0.1.fc19.x86_64
Comment 5 Joachim Backes 2013-10-15 09:48:27 EDT
Created attachment 812541 [details]
LO document with wrong printed table line background (is light gray!)

As I mentionted already, the light gray color is printed to dark on my samsung b/w laserprinter (ml-1660), and the light gray is not dithered correctly (there is a weird moiré in the gray area I never had in previous printouts).
Comment 6 Tim Waugh 2013-10-15 12:37:58 EDT
OK.

I think you may have been right about it being related to colour management. The cups-filters package in Fedora 19 "testing" obsoletes ghostscript-cups and provides its own versions of those filters. In theory, since the filters are the same, it shouldn't have made any difference. However, I think it fixes a long-standing bug in the colord client code, meaning that it will have started to do colour management correctly.

To see if that's the case, let's compare debug logs for CUPS before and after the update.  Here's how:

1. Downgrade cups-filters to 1.0.38-2.fc19 again
2. Turn on debugging with "cupsctl --debug-logging" (as root)
3. Submit a print job
4. Upgrade cups-filters to the "not-working" version
5. Submit another print job
6. Turn off debugging with "cupsctl --no-debug-logging" (as root)

Now, 'lpstat -Wcompleted -o' should list all the jobs -- we're only interested in the most recent two. Note their job numbers, and then filter out debug logs from those jobs:
e.g.
grep 'Job 21' /var/log/cups/error_log > job21.log

Then please attach the logs from both jobs.
Comment 7 Joachim Backes 2013-10-16 00:18:36 EDT
Created attachment 812741 [details]
Good printout

The gray color has been printed well
Comment 8 Joachim Backes 2013-10-16 00:20:36 EDT
Created attachment 812742 [details]
Bad printout

The gray parts habe been printed bad
Comment 9 Tim Waugh 2013-10-16 05:56:18 EDT
OK, thanks. They are using different filter chains:

GOOD: pdftopdf | gstoraster  | rastertoqpdl
BAD : pdftopdf | pdftoraster | rastertoqpdl

I wonder why pdftoraster is getting used? I bet it's to do with cups-filters obsoleting ghostscript-cups.
Comment 10 Fedora Update System 2013-10-16 07:55:02 EDT
ghostscript-9.10-4.fc19,cups-filters-1.0.40-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ghostscript-9.10-4.fc19,cups-filters-1.0.40-3.fc19
Comment 11 Tim Waugh 2013-10-16 07:58:42 EDT
So, the reason was that the cups-filters spec file still removed the gstoraster MIME convs filter in order to avoid a conflict with ghostscript-cups. Fixed now by: not removing that convs filter, and also shipping a ghostscript that doesn't supply the ghostscript-cups filters.
Comment 12 Tim Waugh 2013-10-16 08:01:21 EDT
Oh... one other thing. After applying the update, but before testing, you might need to restart cups: systemctl restart cups.service. (Only necessary if you have the previous updates-testing package installed.)
Comment 13 Fedora Update System 2013-10-16 08:02:46 EDT
cups-filters-1.0.40-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2013-18453/cups-filters-1.0.40-3.fc20
Comment 14 Joachim Backes 2013-10-16 08:04:10 EDT
Print is gooooood with cups-filters-1.0.40-3.fc20!

Thank you very much!
Comment 15 Fedora Update System 2013-10-17 16:34:40 EDT
Package cups-filters-1.0.40-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-filters-1.0.40-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18453/cups-filters-1.0.40-3.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2013-10-18 15:50:58 EDT
ghostscript-9.10-4.fc19, cups-filters-1.0.40-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2013-10-23 13:30:28 EDT
Package cups-filters-1.0.40-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cups-filters-1.0.40-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18453/cups-filters-1.0.40-4.fc20
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2013-11-10 01:38:31 EST
cups-filters-1.0.40-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.