Bug 1019262 - Datasource is not removed from EAP 5 server till its restart
Datasource is not removed from EAP 5 server till its restart
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.2
Unspecified Unspecified
medium Severity high
: ER04
: JON 3.3.0
Assigned To: Thomas Segismont
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 07:32 EDT by Radim Hatlapatka
Modified: 2014-09-22 06:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-22 06:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radim Hatlapatka 2013-10-15 07:32:04 EDT
Description of problem:
In order to really remove datasource it is necessary to restart EAP 5 server but user of JON is not informed about it.

This is regression to the behavior of JON 3.1.2 where datasource was removed from the server without need of restart

Version-Release number of selected component (if applicable):
JON 3.2.0.ER3 vs EAP 5.2.0


How reproducible: always


Steps to Reproduce:
1. import EAP5 to JON server
2. create for example XA Datasource named testXADS
3. look to EAP 5 jmx console to jboss.jdbc:datasource=testXADS,service=metadata
4. remove created XA Datasource via JON
5. see via jmx console that the datasource is unchanged in EAP 5
- after you reboot EAP 5 server the datasource is finally removed


Actual results:
datasource is not removed from EAP 5 server before actual restart of the server and at the same time user is not informed about it

Expected results:
datasource should be removed without any need of restart


Additional info:
Comment 1 Radim Hatlapatka 2013-10-17 12:05:01 EDT
The same goes for Queues and Topics
Comment 2 Simeon Pinder 2013-11-08 09:41:39 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 4 Jay Shaughnessy 2014-09-04 15:05:34 EDT
Are we sure this a regression from 3.1.2 or was it a change from the behavior of managing EAP4 instances?
Comment 5 Radim Hatlapatka 2014-09-09 06:24:24 EDT
Yes, we are sure that with JON 3.1.2 user didn't have to restart the server. It definitely isn't caused by change in EAP 5 (before it was also tested with EAP 5.2)
Comment 6 Jay Shaughnessy 2014-09-09 11:09:51 EDT
OK, we will try and fit this into 3.3.0, assigning to Thomas for further evaluation.
Comment 7 Thomas Segismont 2014-09-22 06:10:19 EDT
This is not a bug in the EAP5 plugin.

The datasource ManagedComponent is correctly removed and the parent deployment as well (leading to removal of the xxx-ds.xml file). It's just a JMX Bean which is left behind, and the EAP5 plugin has no control on it.

Creating a datasource with the same JNDI name after removal works.

The profile service should remove the JMX Bean. Consider opening a BZ against EAP5.

Note You need to log in before you can comment on or make changes to this bug.