Bug 1019270 - can't enable autostart for MariaDB service
can't enable autostart for MariaDB service
Status: CLOSED DUPLICATE of bug 1014311
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 07:52 EDT by Mikhail
Modified: 2013-10-15 09:07 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 09:07:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikhail 2013-10-15 07:52:35 EDT
Description of problem:
[root@localhost ~]# chkconfig mysqld on
Note: Forwarding request to 'systemctl enable mysqld.service'.
Failed to issue method call: No such file or directory
[root@localhost ~]# service mysqld start
Redirecting to /bin/systemctl start  mysqld.service
[root@localhost ~]# yum reinstall mariadb-server
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package mariadb-server.x86_64 1:5.5.33a-2.fc20 will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================================================================================
 Package                                             Arch                                        Version                                                Repository                                            Size
===================================================================================================================================================================================================================
Reinstalling:
 mariadb-server                                      x86_64                                      1:5.5.33a-2.fc20                                       updates-testing                                       11 M

Transaction Summary
===================================================================================================================================================================================================================
Reinstall  1 Package

Total download size: 11 M
Installed size: 56 M
Is this ok [y/d/N]: y
Downloading packages:
mariadb-server-5.5.33a-2.fc20.x86_64.rpm                                                                                                                                                    |  11 MB  00:00:02     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : 1:mariadb-server-5.5.33a-2.fc20.x86_64                                                                                                                                                          1/1 
  Verifying  : 1:mariadb-server-5.5.33a-2.fc20.x86_64                                                                                                                                                          1/1 

Installed:
  mariadb-server.x86_64 1:5.5.33a-2.fc20                                                                                                                                                                           

Complete!
[root@localhost ~]# chkconfig mysqld on
Note: Forwarding request to 'systemctl enable mysqld.service'.
Failed to issue method call: No such file or directory
Comment 1 Michal Schmidt 2013-10-15 08:43:10 EDT
Does it work if you use the name "mariadb" instead of "mysqld"?
If so, this is likely a duplicate of bug 1014311.
Comment 2 Mikhail 2013-10-15 09:07:13 EDT
Thanks it's really helps

[root@localhost ~]# chkconfig mariadb on
Note: Forwarding request to 'systemctl enable mariadb.service'.
ln -s '/usr/lib/systemd/system/mariadb.service' '/etc/systemd/system/multi-user.target.wants/mariadb.service'
Comment 3 Michal Schmidt 2013-10-15 09:07:57 EDT

*** This bug has been marked as a duplicate of bug 1014311 ***

Note You need to log in before you can comment on or make changes to this bug.