This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019273 - [RFE] vdsm should be able to monitor domains also when not connected to a pool
[RFE] vdsm should be able to monitor domains also when not connected to a pool
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Federico Simoncelli
Meital Bourvine
storage
: FutureFeature
Depends On:
Blocks: 1019470 3.3snap1
  Show dependency treegraph
 
Reported: 2013-10-15 07:57 EDT by Federico Simoncelli
Modified: 2016-02-10 15:24 EST (History)
11 users (show)

See Also:
Fixed In Version: is20
Doc Type: Enhancement
Doc Text:
VDSM can now monitor domains when not connected to a pool using the startMonitoringDomain and stopMonitoringDomain options. Monitoring results can be obtained with repoStats().
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:18:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20190 None None None Never
oVirt gerrit 20191 None None None Never
oVirt gerrit 20192 None None None Never
oVirt gerrit 20193 None None None Never
oVirt gerrit 20194 None None None Never

  None (edit)
Description Federico Simoncelli 2013-10-15 07:57:02 EDT
Description of problem:
vdsm should be able to monitor domains also when not connected to a pool.
E.g.:

startMonitoringDomain() should be added for monitoring a storage domain     without being connected to the pool and getting and ID for such SD lockspace.
    
stopMonitoringDomain() should stops the monitoring and releases the ID.
    
Monitoring results could be gathered with repoStats().
Comment 1 Charlie 2013-11-27 19:29:00 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 2 Meital Bourvine 2014-01-06 04:33:16 EST
Is it only for hosted engine?

How can I reach this state from the UI? What are the reproduction steps?
Comment 3 Meital Bourvine 2014-01-06 09:21:08 EST
Verified on IS29:

[root@master-vds13 ~]# vdsClient -s 0 getStorageDomainsList
12bfef7f-15bc-4196-9cb4-1b09b211f5a4
65027b13-6b68-4d0e-a048-e003b10c2b22
3b2e987b-aa57-4713-832a-2c57bbf29204

[root@master-vds13 ~]# vdsClient -s 0 getConnectedStoragePoolsList

[root@master-vds13 ~]# vdsClient -s 0 repoStats

[root@master-vds13 ~]# vdsClient -s 0 getConnectedStoragePoolsList

[root@master-vds13 ~]# vdsClient -s 0 startMonitoringDomain 65027b13-6b68-4d0e-a048-e003b10c2b22 9
OK
[root@master-vds13 ~]# vdsClient -s 0 repoStats
Domain 65027b13-6b68-4d0e-a048-e003b10c2b22 {'code': 0, 'version': 3, 'acquired': False, 'delay': '0.000752342', 'lastCheck': '4.0', 'valid': True}

[root@master-vds13 ~]# vdsClient -s 0 getConnectedStoragePoolsList

[root@master-vds13 ~]# vdsClient -s 0 stopMonitoringDomain 65027b13-6b68-4d0e-a048-e003b10c2b22
OK
[root@master-vds13 ~]# vdsClient -s 0 repoStats

[root@master-vds13 ~]# vdsClient -s 0 getConnectedStoragePoolsList
Comment 5 errata-xmlrpc 2014-01-21 11:18:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.