This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019285 - sssd_be crashes sometime when installing ipa-client
sssd_be crashes sometime when installing ipa-client
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jakub Hrozek
Kaushik Banerjee
:
: 1068907 (view as bug list)
Depends On: 1051164
Blocks: 1061410
  Show dependency treegraph
 
Reported: 2013-10-15 08:12 EDT by Namita Soman
Modified: 2014-10-14 00:46 EDT (History)
9 users (show)

See Also:
Fixed In Version: sssd-1.11.5.1-1.el6
Doc Type: Bug Fix
Doc Text:
Do not document.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attaching back trace (4.36 KB, text/plain)
2013-10-15 08:12 EDT, Namita Soman
no flags Details
verification steps with console output (7.48 KB, text/plain)
2014-07-11 09:52 EDT, Kaleem
no flags Details

  None (edit)
Description Namita Soman 2013-10-15 08:12:45 EDT
Created attachment 812471 [details]
attaching back trace

Description of problem:
When running the ipa-client-install test suite, sssd_be crashed. In matching timestamps, the test that was running at the time was to install client using preserve-sssd, and the uninstall of this client may have caused it. But wasn't able to replicate the crash again

Pavel took a look, and suggested it might be related to 
https://fedorahosted.org/sssd/ticket/1751

Version-Release number of selected component (if applicable):
sssd-1.9.2-128

How reproducible:
saw it once

Steps to Reproduce:
listed below in "additional info"


Actual results:
sssd_be crashed

Expected results:
no crash

Additional info:
The goal of the test is to install client using the option --preserve-sssd, and verify the install didn't overwrite it.

the steps are:
# cat /etc/sssd/sssd.conf
[sssd]
config_file_version = 2
domains = LDAP-KRB5
debug_level = 6
reconnection_retries = 3
services = nss, pam

[nss]
filter_groups = root
filter_users = root

[pam]

[domain/LDAP-KRB5]
id_provider = ldap
auth_provider = krb5
ldap_uri = ldap://<hostname>
debug_level = 9
krb5_server = ivanova.testrelm.com
krb5_realm = TESTRELM.COM

# chmod 0600 /etc/sssd/sssd.conf
# authconfig --enablesssd --enablesssdauth --updateall
# service sssd stop
# service sssd start
# perl -pi -e 's/EXAMPLE.COM/TESTRELM.COM/g' /etc/krb5.conf
# perl -pi -e 's/example.com/testrelm.com/g' /etc/krb5.conf
# perl -pi -e 's/kerberos.example.com/ivanova.testrelm.com/g' /etc/krb5.conf
# ls -lZ /etc/krb5.conf
# ipa-client-install --domain=testrelm.com --realm=TESTRELM.COM  -p admin -w <password>  --server=<hostname> --preserve-sssd
# ausearch -m avc -ts $AVCCHKTS -su root:system_r:sssd_t:s0 -o root:object_r:etc_t:s0 |grep name=\"krb5.conf\"|wc -l
# kinit admin
# ipa-client-install --uninstall
# mv /etc/sssd/sssd.conf /etc/sssd/sssd.conf.old.nk
# service ntpd stop
# ipa-client-install --uninstall
# hostname localhost.localdomain
# ipa-client-install --domain=testrelm.com --realm=TESTRELM.COM -p admin -w <password> --unattended --server=<hostname>
Comment 2 Jakub Hrozek 2013-10-17 05:08:54 EDT
Upstream ticket:
https://fedorahosted.org/sssd/ticket/1751
Comment 3 RHEL Product and Program Management 2013-10-20 05:14:29 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jakub Hrozek 2013-10-31 07:34:17 EDT
We have a workaround available, so I'm just marking this as assigned so far. I'd prefer to have a real fix.
Comment 5 Jakub Hrozek 2014-03-05 11:08:09 EST
Fixed upstream: 3082504f4fb4e4efdc50c99369204e5b2cfac40e
Comment 7 Jakub Hrozek 2014-05-29 05:21:35 EDT
*** Bug 1068907 has been marked as a duplicate of this bug. ***
Comment 8 Kaleem 2014-07-11 09:51:20 EDT
Verified.

sssd, ipa-client rpm version:
=============================
[root@rhel66-client1 ~]# rpm -q ipa-client sssd
ipa-client-3.0.0-42.el6.x86_64
sssd-1.11.6-1.el6.x86_64
[root@rhel66-client1 ~]# 

Please find the attached console output as verification log.
Comment 9 Kaleem 2014-07-11 09:52:05 EDT
Created attachment 917317 [details]
verification steps with console output
Comment 10 errata-xmlrpc 2014-10-14 00:46:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1375.html

Note You need to log in before you can comment on or make changes to this bug.