Bug 1019334 - ksh monitor mode documented contrary to what it actually does
ksh monitor mode documented contrary to what it actually does
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michal Hlavinka
Martin Kyral
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 09:56 EDT by Martin Kyral
Modified: 2014-11-05 05:15 EST (History)
2 users (show)

See Also:
Fixed In Version: ksh-20120801-16.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1100215 (view as bug list)
Environment:
Last Closed: 2014-10-14 03:04:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kyral 2013-10-15 09:56:44 EDT
Description of problem:

on ksh-20120801-9.el6:
ksh -m test.ksh -> xterms survive the script
ksh test.ksh -> xterms die with the script

However, the man page says contrary: "The INT and QUIT signals for an invoked command are ignored if the command is followed by & and the monitor option is not active."

This seems to be documentation bug as:
1) the ksh monitor mode behavior has been discussed with David Korn
2) bash man page says: "...keyboard-generated signals such as SIGINT... Background processes are  those  whose process  group  ID  differs  from  the terminal’s; such processes are immune to keyboard-generated signals." which is the same as the fixed ksh do.


Version-Release number of selected component (if applicable):
ksh-20120801-9.el6
Comment 3 errata-xmlrpc 2014-10-14 03:04:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1381.html

Note You need to log in before you can comment on or make changes to this bug.