Bug 1019389 - When auto-attaching subscription to system, status icon is black, not green
When auto-attaching subscription to system, status icon is black, not green
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Christine Fouant
Sachin Ghai
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 11:30 EDT by Corey Welton
Modified: 2016-04-22 12:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:06:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot snippet (15.08 KB, image/png)
2013-10-15 11:33 EDT, Corey Welton
no flags Details
subscription color is green after auto-attaching subscription to content-host (34.17 KB, image/png)
2014-06-09 03:41 EDT, Sachin Ghai
no flags Details
subscription color is red (42.17 KB, image/png)
2014-06-09 03:42 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6002 None None None 2016-04-22 12:42 EDT

  None (edit)
Description Corey Welton 2013-10-15 11:30:21 EDT
Description of problem:

When an out-of-compliance system has a subscription auto-attached, the status is changed to valid, but the expected red/green is black.

Version-Release number of selected component (if applicable):
Satellite-6.0.2-RHEL-6-20131011.0


How reproducible:


Steps to Reproduce:
1.  register system to sat (node?) but do not apply subscriptions 
2.  In webui, auto-attach subscription
3.  View results in webui.

Actual results:

Subscription Status  valid (with black icon)


Expected results:

Icon should be appropriately illustrated


Additional info:
see forthcoming screenshot
Comment 1 Corey Welton 2013-10-15 11:33:46 EDT
Created attachment 812593 [details]
screenshot snippet
Comment 3 Christine Fouant 2014-05-30 14:42:53 EDT
Created redmine issue http://projects.theforeman.org/issues/6002 from this bug
Comment 4 Bryan Kearney 2014-06-03 13:51:31 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/6002 has been closed
Comment 6 Sachin Ghai 2014-06-09 03:39:45 EDT
Verified with sat6 beta snap8 (Satellite-6.0.3-RHEL-6-20140604.0)

I can see status icon green after auto attaching subscriptions to content-host. If content-host is out-of-compliance then UI shows red color. Please see attachements for verification.
Comment 7 Sachin Ghai 2014-06-09 03:41:31 EDT
Created attachment 904570 [details]
subscription color is green after auto-attaching subscription to content-host
Comment 8 Sachin Ghai 2014-06-09 03:42:26 EDT
Created attachment 904571 [details]
subscription color is red
Comment 9 Bryan Kearney 2014-07-02 10:06:56 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.