Bug 1019410 - 'pcs stonith level add' gives "Error: <node> is not currently a node (use --force to override)"
'pcs stonith level add' gives "Error: <node> is not currently a node (use --...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcs (Show other bugs)
6.5
All Linux
high Severity high
: rc
: ---
Assigned To: Chris Feist
: Reopened, ZStream
Depends On:
Blocks: 1038477 1038479
  Show dependency treegraph
 
Reported: 2013-10-15 12:17 EDT by John Ruemker
Modified: 2014-10-14 03:21 EDT (History)
6 users (show)

See Also:
Fixed In Version: pcs-0.9.101-1.el6
Doc Type: Bug Fix
Doc Text:
When adding a STONITH fencing level, pcs sometimes mistakenly detected that some nodes were not a part of the cluster. As a result, it was not possible to add a STONITH level unless the "--force" option was used. Now, pcs correctly determines whether a node is a part of the cluster and, as long as a valid node is used, adding a pcs STONITH level no longer requires the use of the "--force" option.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:21:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 513213 None None None Never

  None (edit)
Description John Ruemker 2013-10-15 12:17:14 EDT
Description of problem: Adding stonith level fails, but succeeds with --force:

# pcs status
Cluster name: jrummy6p
Last updated: Tue Oct 15 11:58:24 2013
Last change: Tue Oct 15 11:51:45 2013 via cibadmin on jrummy6p-2-clust
Stack: cman
Current DC: jrummy6p-2-clust - partition with quorum
Version: 1.1.10-14.el6-368c726
2 Nodes configured
2 Resources configured


Online: [ jrummy6p-1-clust jrummy6p-2-clust ]

Full list of resources:

 jrummy6p-1-xvm	(stonith:fence_xvm):	Started jrummy6p-1-clust 
 jrummy6p-2-xvm	(stonith:fence_xvm):	Started jrummy6p-2-clust 

# pcs stonith level add 1 jrummy6p-1-clust jrummy6p-1-xvm
Error: jrummy6p-1-clust is not currently a node (use --force to override)

# pcs cluster cib
<cib epoch="14" num_updates="5" admin_epoch="0" validate-with="pacemaker-1.2" cib-last-written="Tue Oct 15 11:51:45 2013" update-origin="jrummy6p-2-clust" update-client="cibadmin" crm_feature_set="3.0.7" have-quorum="1" dc-uuid="jrummy6p-2-clust">
  <configuration>
    <crm_config>
      <cluster_property_set id="cib-bootstrap-options">
        <nvpair id="cib-bootstrap-options-dc-version" name="dc-version" value="1.1.10-14.el6-368c726"/>
        <nvpair id="cib-bootstrap-options-cluster-infrastructure" name="cluster-infrastructure" value="cman"/>
      </cluster_property_set>
    </crm_config>
    <nodes>
      <node id="jrummy6p-2-clust" uname="jrummy6p-2-clust"/>
      <node id="jrummy6p-1-clust" uname="jrummy6p-1-clust"/>
    </nodes>
    <resources>
      <primitive class="stonith" id="jrummy6p-1-xvm" type="fence_xvm">
        <instance_attributes id="jrummy6p-1-xvm-instance_attributes">
          <nvpair id="jrummy6p-1-xvm-instance_attributes-domain" name="domain" value="jrummy6p-1"/>
        </instance_attributes>
        <operations>
          <op id="jrummy6p-1-xvm-monitor-interval-60s" interval="60s" name="monitor"/>
        </operations>
      </primitive>
      <primitive class="stonith" id="jrummy6p-2-xvm" type="fence_xvm">
        <instance_attributes id="jrummy6p-2-xvm-instance_attributes"/>
        <operations>
          <op id="jrummy6p-2-xvm-monitor-interval-60s" interval="60s" name="monitor"/>
        </operations>
      </primitive>
    </resources>
    <constraints/>
  </configuration>
  <status>
    <node_state id="jrummy6p-1-clust" uname="jrummy6p-1-clust" in_ccm="true" crmd="online" crm-debug-origin="do_update_resource" join="member" expected="member">
      <lrm id="jrummy6p-1-clust">
        <lrm_resources>
          <lrm_resource id="jrummy6p-1-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-1-xvm_last_0" operation_key="jrummy6p-1-xvm_start_0" operation="start" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="7:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;7:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="62" rc-code="0" op-status="0" interval="0" last-run="1381852274" last-rc-change="1381852274" exec-time="58" queue-time="0" op-digest="c77bab59961cd0c21dfe973e68c8e298"/>
            <lrm_rsc_op id="jrummy6p-1-xvm_monitor_60000" operation_key="jrummy6p-1-xvm_monitor_60000" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="8:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;8:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="65" rc-code="0" op-status="0" interval="60000" last-rc-change="1381852275" exec-time="35" queue-time="0" op-digest="393e948b6d45cc201cad2f5bebc2c3fb"/>
          </lrm_resource>
          <lrm_resource id="jrummy6p-2-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-2-xvm_last_0" operation_key="jrummy6p-2-xvm_monitor_0" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="5:16:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:7;5:16:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="70" rc-code="7" op-status="0" interval="0" last-run="1381852306" last-rc-change="1381852306" exec-time="0" queue-time="0" op-digest="f2317cad3d54cec5d7d7aa7d0bf35cf8"/>
          </lrm_resource>
        </lrm_resources>
      </lrm>
      <transient_attributes id="jrummy6p-1-clust">
        <instance_attributes id="status-jrummy6p-1-clust">
          <nvpair id="status-jrummy6p-1-clust-probe_complete" name="probe_complete" value="true"/>
        </instance_attributes>
      </transient_attributes>
    </node_state>
    <node_state id="jrummy6p-2-clust" uname="jrummy6p-2-clust" in_ccm="true" crmd="online" crm-debug-origin="do_update_resource" join="member" expected="member">
      <lrm id="jrummy6p-2-clust">
        <lrm_resources>
          <lrm_resource id="jrummy6p-1-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-1-xvm_last_0" operation_key="jrummy6p-1-xvm_monitor_0" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="6:15:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:7;6:15:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="26" rc-code="7" op-status="0" interval="0" last-run="1381852274" last-rc-change="1381852274" exec-time="0" queue-time="0" op-digest="c77bab59961cd0c21dfe973e68c8e298"/>
          </lrm_resource>
          <lrm_resource id="jrummy6p-2-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-2-xvm_last_0" operation_key="jrummy6p-2-xvm_start_0" operation="start" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="10:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;10:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="34" rc-code="0" op-status="0" interval="0" last-run="1381852305" last-rc-change="1381852305" exec-time="2973" queue-time="0" op-digest="f2317cad3d54cec5d7d7aa7d0bf35cf8"/>
            <lrm_rsc_op id="jrummy6p-2-xvm_monitor_60000" operation_key="jrummy6p-2-xvm_monitor_60000" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="11:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;11:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="37" rc-code="0" op-status="0" interval="60000" last-rc-change="1381852309" exec-time="36" queue-time="0" op-digest="4811cef7f7f94e3a35a70be7916cb2fd"/>
          </lrm_resource>
        </lrm_resources>
      </lrm>
      <transient_attributes id="jrummy6p-2-clust">
        <instance_attributes id="status-jrummy6p-2-clust">
          <nvpair id="status-jrummy6p-2-clust-probe_complete" name="probe_complete" value="true"/>
        </instance_attributes>
      </transient_attributes>
    </node_state>
  </status>
</cib>


# pcs stonith level add 1 jrummy6p-1-clust jrummy6p-1-xvm --force
# pcs stonith level
 Node: jrummy6p-1-clust
  Level 1 - jrummy6p-1-xvm

# pcs cluster cib
<cib epoch="15" num_updates="1" admin_epoch="0" validate-with="pacemaker-1.2" cib-last-written="Tue Oct 15 12:11:13 2013" update-origin="jrummy6p-2-clust" update-client="cibadmin" crm_feature_set="3.0.7" have-quorum="1" dc-uuid="jrummy6p-2-clust">
  <configuration>
    <crm_config>
      <cluster_property_set id="cib-bootstrap-options">
        <nvpair id="cib-bootstrap-options-dc-version" name="dc-version" value="1.1.10-14.el6-368c726"/>
        <nvpair id="cib-bootstrap-options-cluster-infrastructure" name="cluster-infrastructure" value="cman"/>
      </cluster_property_set>
    </crm_config>
    <nodes>
      <node id="jrummy6p-2-clust" uname="jrummy6p-2-clust"/>
      <node id="jrummy6p-1-clust" uname="jrummy6p-1-clust"/>
    </nodes>
    <resources>
      <primitive class="stonith" id="jrummy6p-1-xvm" type="fence_xvm">
        <instance_attributes id="jrummy6p-1-xvm-instance_attributes">
          <nvpair id="jrummy6p-1-xvm-instance_attributes-domain" name="domain" value="jrummy6p-1"/>
        </instance_attributes>
        <operations>
          <op id="jrummy6p-1-xvm-monitor-interval-60s" interval="60s" name="monitor"/>
        </operations>
      </primitive>
      <primitive class="stonith" id="jrummy6p-2-xvm" type="fence_xvm">
        <instance_attributes id="jrummy6p-2-xvm-instance_attributes"/>
        <operations>
          <op id="jrummy6p-2-xvm-monitor-interval-60s" interval="60s" name="monitor"/>
        </operations>
      </primitive>
    </resources>
    <constraints/>
    <fencing-topology>
      <fencing-level devices="jrummy6p-1-xvm" id="fl-jrummy6p-1-clust-1" index="1" target="jrummy6p-1-clust"/>
    </fencing-topology>
  </configuration>
  <status>
    <node_state id="jrummy6p-1-clust" uname="jrummy6p-1-clust" in_ccm="true" crmd="online" crm-debug-origin="do_update_resource" join="member" expected="member">
      <lrm id="jrummy6p-1-clust">
        <lrm_resources>
          <lrm_resource id="jrummy6p-1-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-1-xvm_last_0" operation_key="jrummy6p-1-xvm_start_0" operation="start" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="7:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;7:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="62" rc-code="0" op-status="0" interval="0" last-run="1381852274" last-rc-change="1381852274" exec-time="58" queue-time="0" op-digest="c77bab59961cd0c21dfe973e68c8e298"/>
            <lrm_rsc_op id="jrummy6p-1-xvm_monitor_60000" operation_key="jrummy6p-1-xvm_monitor_60000" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="8:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;8:15:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="65" rc-code="0" op-status="0" interval="60000" last-rc-change="1381852275" exec-time="35" queue-time="0" op-digest="393e948b6d45cc201cad2f5bebc2c3fb"/>
          </lrm_resource>
          <lrm_resource id="jrummy6p-2-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-2-xvm_last_0" operation_key="jrummy6p-2-xvm_monitor_0" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="5:16:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:7;5:16:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="70" rc-code="7" op-status="0" interval="0" last-run="1381852306" last-rc-change="1381852306" exec-time="0" queue-time="0" op-digest="f2317cad3d54cec5d7d7aa7d0bf35cf8"/>
          </lrm_resource>
        </lrm_resources>
      </lrm>
      <transient_attributes id="jrummy6p-1-clust">
        <instance_attributes id="status-jrummy6p-1-clust">
          <nvpair id="status-jrummy6p-1-clust-probe_complete" name="probe_complete" value="true"/>
        </instance_attributes>
      </transient_attributes>
    </node_state>
    <node_state id="jrummy6p-2-clust" uname="jrummy6p-2-clust" in_ccm="true" crmd="online" crm-debug-origin="do_update_resource" join="member" expected="member">
      <lrm id="jrummy6p-2-clust">
        <lrm_resources>
          <lrm_resource id="jrummy6p-1-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-1-xvm_last_0" operation_key="jrummy6p-1-xvm_monitor_0" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="6:15:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:7;6:15:7:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="26" rc-code="7" op-status="0" interval="0" last-run="1381852274" last-rc-change="1381852274" exec-time="0" queue-time="0" op-digest="c77bab59961cd0c21dfe973e68c8e298"/>
          </lrm_resource>
          <lrm_resource id="jrummy6p-2-xvm" type="fence_xvm" class="stonith">
            <lrm_rsc_op id="jrummy6p-2-xvm_last_0" operation_key="jrummy6p-2-xvm_start_0" operation="start" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="10:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;10:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="34" rc-code="0" op-status="0" interval="0" last-run="1381852305" last-rc-change="1381852305" exec-time="2973" queue-time="0" op-digest="f2317cad3d54cec5d7d7aa7d0bf35cf8"/>
            <lrm_rsc_op id="jrummy6p-2-xvm_monitor_60000" operation_key="jrummy6p-2-xvm_monitor_60000" operation="monitor" crm-debug-origin="do_update_resource" crm_feature_set="3.0.7" transition-key="11:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" transition-magic="0:0;11:16:0:8e30aeb3-98e7-43ec-bfad-3c70cdc12410" call-id="37" rc-code="0" op-status="0" interval="60000" last-rc-change="1381852309" exec-time="36" queue-time="0" op-digest="4811cef7f7f94e3a35a70be7916cb2fd"/>
          </lrm_resource>
        </lrm_resources>
      </lrm>
      <transient_attributes id="jrummy6p-2-clust">
        <instance_attributes id="status-jrummy6p-2-clust">
          <nvpair id="status-jrummy6p-2-clust-probe_complete" name="probe_complete" value="true"/>
        </instance_attributes>
      </transient_attributes>
    </node_state>
  </status>
</cib>



Version-Release number of selected component (if applicable):
pcs-0.9.90-2.el6.noarch
pacemaker-1.1.10-14.el6.x86_64

How reproducible: Unknown


Steps to Reproduce: See above


Actual results: stonith level fails to be added


Expected results: stonith level is added


Additional info:
Comment 2 RHEL Product and Program Management 2013-10-18 13:09:46 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Chris Feist 2013-11-05 15:20:20 EST
For now we'll have to use --force as a workaround.
Comment 4 xrobau 2013-11-15 17:58:04 EST
Note that this is a similar issue to 1029129 - it's trying to use the Corosync Conf to find node names, rather than asking pacemaker.
Comment 5 Chris Feist 2013-12-04 19:17:41 EST
Before Fix:
[root@ask-02 test]# rpm -q pcs
pcs-0.9.90-2.el6.noarch
[root@ask-02 test]# pcs stonith
 myfence	(stonith:fence_apc):	Stopped 
[root@ask-02 test]# pcs stonith level add 1 ask-02 myfence
Error: ask-02 is not currently a node (use --force to override)


After Fix:
[root@ask-02 test]# rpm -q pcs
pcs-0.9.101-1.el6.noarch
[root@ask-02 test]# pcs stonith level add 1 ask-02 myfence
[root@ask-02 test]# pcs stonith level
 Node: ask-02
  Level 1 - myfence
Comment 13 errata-xmlrpc 2014-10-14 03:21:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1526.html

Note You need to log in before you can comment on or make changes to this bug.