Bug 1019438 - SELinux is preventing /usr/sbin/glusterfsd from 'unlink' accesses on the sock_file 204632be8e98e418b07cf4a7dc8a06a0.socket.
SELinux is preventing /usr/sbin/glusterfsd from 'unlink' accesses on the sock...
Status: CLOSED DUPLICATE of bug 1019431
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:726625f90b1b90fefd8f2460d65...
:
: 1198403 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 13:18 EDT by Eric Blake
Modified: 2015-03-04 06:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 16:04:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Blake 2013-10-15 13:18:35 EDT
Description of problem:
trying to restart a gluster volume with different settings:
gluster> volume set vol1 server.allow-insecure on
volume set: success
gluster> volume stop vol1
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: vol1: success
gluster> volume start vol1
volume start: vol1: failed: Commit failed on localhost. Please check the log file for more details.

with /var/log/glusterfs/etc-glusterfs-glusterd.vol.log containing:

[2013-10-15 17:11:54.375444] E [glusterd-utils.c:1493:glusterd_brick_unlink_sock
et_file] 0-management: Failed to remove /var/run/204632be8e98e418b07cf4a7dc8a06a
0.socket error: Permission denied
[2013-10-15 17:11:55.244479] I [glusterd-pmap.c:271:pmap_registry_remove] 0-pmap
: removing brick /brick on port 49152
[2013-10-15 17:11:55.933104] W [socket.c:514:__socket_rwv] 0-management: readv f
ailed (No data available)
[2013-10-15 17:11:58.936269] W [socket.c:514:__socket_rwv] 0-management: readv f
ailed (No data available)
[2013-10-15 17:11:59.022854] E [glusterd-utils.c:4142:glusterd_brick_start] 0-ma
nagement: Unable to start brick red:/brick
[2013-10-15 17:11:59.022893] E [glusterd-syncop.c:840:gd_commit_op_phase] 0-mana
gement: Commit of operation 'Volume Start' failed on localhost    
SELinux is preventing /usr/sbin/glusterfsd from 'unlink' accesses on the sock_file 204632be8e98e418b07cf4a7dc8a06a0.socket.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that glusterfsd should be allowed unlink access on the 204632be8e98e418b07cf4a7dc8a06a0.socket sock_file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep glusterd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:glusterd_t:s0
Target Context                system_u:object_r:var_run_t:s0
Target Objects                204632be8e98e418b07cf4a7dc8a06a0.socket [
                              sock_file ]
Source                        glusterd
Source Path                   /usr/sbin/glusterfsd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           glusterfs-3.4.1-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.9.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.7-200.fc19.x86_64 #1 SMP Thu
                              Aug 15 23:19:45 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-10-15 11:11:54 MDT
Last Seen                     2013-10-15 11:11:54 MDT
Local ID                      bc6a81bb-a09d-4327-ba60-897fcb067614

Raw Audit Messages
type=AVC msg=audit(1381857114.374:1503): avc:  denied  { unlink } for  pid=23960 comm="glusterd" name="204632be8e98e418b07cf4a7dc8a06a0.socket" dev="tmpfs" ino=27374 scontext=system_u:system_r:glusterd_t:s0 tcontext=system_u:object_r:var_run_t:s0 tclass=sock_file


type=SYSCALL msg=audit(1381857114.374:1503): arch=x86_64 syscall=unlink success=no exit=EACCES a0=7ff1df4f1fc0 a1=7ff1d97deba7 a2=7ff1df4f1ff0 a3=20 items=0 ppid=1 pid=23960 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=glusterd exe=/usr/sbin/glusterfsd subj=system_u:system_r:glusterd_t:s0 key=(null)

Hash: glusterd,glusterd_t,var_run_t,sock_file,unlink

Additional info:
reporter:       libreport-2.1.8
hashmarkername: setroubleshoot
kernel:         3.10.7-200.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-10-16 16:04:14 EDT

*** This bug has been marked as a duplicate of bug 1019431 ***
Comment 2 Miroslav Grepl 2015-03-04 06:58:42 EST
*** Bug 1198403 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.