Bug 1019454 - fatal: RPC failed at server. There is no Hardware named 'armv7l'
fatal: RPC failed at server. There is no Hardware named 'armv7l'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
20
arm Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker F21AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-10-15 14:24 EDT by Paul Whalen
Modified: 2014-07-09 14:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-09 14:11:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Whalen 2013-10-15 14:24:38 EDT
Description of problem:
When attempting to report a problem to Bugzilla, reports fails to upload. 


Version-Release number of selected component (if applicable):
libreport-2.1.7-1.fc20

How reproducible:


Steps to Reproduce:
1. Install attempted on ARM using dnf rather than yum
2. Install fails, attempt to use the automatic reporting tool 
3. Report is generated

Actual results:
Upload fails with:

...
Checking for duplicates
Creating a new bug
fatal: RPC failed at server.  There is no Hardware named 'armv7l'.
('report_Bugzilla' exited with 1)


Expected results:
Bug created.

Additional info:
uname -m reports 'armv7l' wheras Bugzilla uses 'arm' for bug reports.
Comment 1 Paul Whalen 2014-05-07 15:17:48 EDT
This problem still exists in F21.
Comment 2 Peter Robinson 2014-05-08 10:08:16 EDT
Ping!?!? With armv7hl being a primary platform this should be supported.
Comment 3 Jakub Filak 2014-05-09 02:27:17 EDT
We can go two ways with this:

1. fast hack - I can add a statement like (strstr("arm", arch) ? "arm" : arch) to libreport's code

2. systematic way - introduce a new variable in /etc/os-release "REDHAT_BUGZILLA_PLATFORM" which will hold the proper value on all architectures

My preferred way is the systematic way because I am a fan of semantic computers and this way is more reliable. On the other hand, the second option requires more work on distribution's side.

Dennis are you willing to add and maintain "REDHAT_BUGZILLA_PLATFORM" variable in /etc/os-release?
Comment 4 Dennis Gilmore 2014-05-09 11:50:02 EDT
there is no way to add what you are asking to /etc/os-release

is the issue that bugzilla does not have armv7l as an arch?
Comment 5 Jakub Filak 2014-05-12 04:18:43 EDT
(In reply to Dennis Gilmore from comment #4)
> is the issue that bugzilla does not have armv7l as an arch?

Yes, ABRT calls 'uname()' to get architecture of crash's machine and then uses the returned string for 'Hardware' field of a new Bugzilla report. This approach works for all architectures except arm. The problem is that Kernel returns 'armv7l' string where Red Hat Bugzilla expects 'arm' string.

I can add a hack to libreport but I would like to fix this issue in a cleaner way.

How about to add 'armv7l' string to the list of Hardware (Platforms)?
Comment 7 John Skeoch 2014-05-19 20:35:45 EDT
armv7l is one of the hardware options now.
Comment 8 Paul Whalen 2014-07-09 14:11:44 EDT
abrt now confirmed working.

Note You need to log in before you can comment on or make changes to this bug.