This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019501 - anaconda lock-up for some time when opening/closing modal dialogs
anaconda lock-up for some time when opening/closing modal dialogs
Status: CLOSED DUPLICATE of bug 1021511
Product: Fedora
Classification: Fedora
Component: xfce4-session (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20BetaFreezeException F20FinalBlocker
  Show dependency treegraph
 
Reported: 2013-10-15 17:38 EDT by Branko Grubić
Modified: 2013-10-23 11:41 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-23 11:41:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (9.98 KB, text/plain)
2013-10-17 14:43 EDT, Branko Grubić
no flags Details
ifcfg.log (1.23 KB, text/plain)
2013-10-17 14:44 EDT, Branko Grubić
no flags Details
program.log (45.33 KB, text/plain)
2013-10-17 14:45 EDT, Branko Grubić
no flags Details
storage.log (293.71 KB, text/plain)
2013-10-17 14:46 EDT, Branko Grubić
no flags Details

  None (edit)
Description Branko Grubić 2013-10-15 17:38:40 EDT
Description of problem:
I was testing F20 BETA TC4 LIVE XFCE image on real hardware, and when I start installer everything is ok until modal dialog pop-up  (for example "Unstable /pre-release "Accept my fate", or dialogs related to partitioning), it freezes GUI, and takes from few seconds to few minutes to show up, same when you click on something in that dialog (buttons tested). I tried to take a picture of it with a program which comes on xfce spin image, but it also messes up by switching between windows ... (anaconda <--> screenshot application) 

While it is unresponsive, top processes are: X, xfwm4 and anaconda

Version-Release number of selected component (if applicable):
anaconda-20.25-1.fc20  (copied from rel-eng ticket for f20 (and TC3/TC4 comment)

How reproducible:


Steps to Reproduce:
1. start XFCE live image
2. run anaconda
3. run until first modal dialog show up

Actual results:
GUI locks-up 

Expected results:
no lock-ups 

Additional info:
Comment 1 Branko Grubić 2013-10-15 18:01:09 EDT
I tested this multiple times, same happens every time, now I think when this happens "double click" _unlock_ the dialog and also double click on "buttons" work. 

I installed xfce live, and everything is ok, anaconda doesn't crash.
Comment 2 Kevin Fenzi 2013-10-16 21:55:38 EDT
I am seeing this too here on bare hardware. Not on virtual installs however. :( 

It's quite odd.
Comment 3 David Shea 2013-10-17 09:43:37 EDT
Is the CD drive spinning up during this lockup? It might be loading the rest of the installer from the disk.
Comment 4 Branko Grubić 2013-10-17 10:38:53 EDT
No, I was using USB flash drive, also I tested TC3 but different desktop (which should be identical to TC4, when it comes to live images, I think only dvd wasn't composed), I used Gnome (Desktop) live image, and it worked there fine.
Comment 5 Branko Grubić 2013-10-17 10:46:25 EDT
Tested TC5 now (xfce), same problem. 
Downloading LXDE to test if it happens on other desktops.
Comment 6 Branko Grubić 2013-10-17 12:13:24 EDT
Ok, one more update (sorry for spam emails!)
Same problem on LXDE live! :(
Comment 7 Brian Lane 2013-10-17 12:41:23 EDT
Please attach the logs from /tmp/*log as individual text/plain attachments to this bug.
Comment 8 Branko Grubić 2013-10-17 14:43:58 EDT
Created attachment 813498 [details]
anaconda.log
Comment 9 Branko Grubić 2013-10-17 14:44:37 EDT
Created attachment 813499 [details]
ifcfg.log
Comment 10 Branko Grubić 2013-10-17 14:45:07 EDT
Created attachment 813500 [details]
program.log
Comment 11 Branko Grubić 2013-10-17 14:46:02 EDT
Created attachment 813501 [details]
storage.log
Comment 12 Branko Grubić 2013-10-17 14:47:24 EDT
packaging and sensitive-info log files are empty (this was just live mode, no install)
Comment 13 Branko Grubić 2013-10-17 19:01:47 EDT
Just to add that TC5 KDE LIVE works fine :S 
So I can see this on LXDE, XFCE for now (gnome and kde are fine). Not sure if this information helps?
Comment 14 Piruthiviraj Natarajan 2013-10-18 11:02:09 EDT
TC5 Live version of XFCE spin CD is better but still could not go all the way through the installation.
Comment 15 Kamil Páral 2013-10-21 11:44:04 EDT
Very probably the same cause as in bug 1021511. Mine is better described, however :-)
Comment 16 Branko Grubić 2013-10-21 11:50:33 EDT
Maybe it is, but I cannot reproduce this on same hw. in other Desktop environments, like KDE, GNOME or MATE. Also how to explain "double click" solution/workaround?
Comment 17 Kamil Páral 2013-10-21 12:45:39 EDT
I've seen the need to double click some buttons in XFCE as well. I guess that it might be caused by the very slow widget performance when lightboxes are displayed, so that some mouse click are simply not registered (or maybe the window is displayed, but the buttons are not sensitive yet, or something).

It's true that this might not be related to bug 1021511 and there is another root issue for this. But I remember seeing this issue usually coupled with lightboxes, so my feeling is that it's related, simply a performance issue.
Comment 18 David Shea 2013-10-21 13:26:10 EDT
*** Bug 1021511 has been marked as a duplicate of this bug. ***
Comment 19 David Shea 2013-10-21 13:29:21 EDT
Did you try to do anything outside of anaconda in xfce? It's kind of ridiculously unresponsive just in general.
Comment 20 Branko Grubić 2013-10-21 13:33:40 EDT
 David Shea, I don't understand how this is now xfce4-session bug, I didn't saw any issues with xfce without anaconda running, also this bug is present in lxde live spin which doesn't have xfce4 components?
Comment 21 Kevin Fenzi 2013-10-21 13:50:04 EDT
I sure didn't see that here on virtual installs or bare metal. All non anaconda gui processes were fine and fast here. 

This also happens in LXDE and other desktops, so I really fail to see how this could be an xfce4-session bug.
Comment 22 Piruthiviraj Natarajan 2013-10-22 06:23:25 EDT
I saw this bug in mate live CD as well.
Comment 23 Kamil Páral 2013-10-23 03:20:43 EDT
If anybody doesn't mind, I would dupe this to bug 1021511. I'm fairly sure it is the same problem. Bug 1021511 contains videos, lists problems in most of available desktop environments and is already accepted as a freeze exception.
Comment 24 Piruthiviraj Natarajan 2013-10-23 08:14:12 EDT
kamil, You should go ahead. Both the bugs are the same IMHO.  Bug 1021511 definitely has more info.
Comment 25 Kamil Páral 2013-10-23 11:41:55 EDT
OK, duping.

*** This bug has been marked as a duplicate of bug 1021511 ***

Note You need to log in before you can comment on or make changes to this bug.