Bug 1019513 - Current geo-replication documentation is incomplete [NEEDINFO]
Current geo-replication documentation is incomplete
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: doc-Administration_Guide (Show other bugs)
2.1
x86_64 All
high Severity high
: ---
: ---
Assigned To: Divya
M S Vishwanath Bhat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 18:34 EDT by Kevin Clevenger
Modified: 2016-05-31 21:56 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 11:48:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kcleveng: needinfo? (mohit_anchlia)


Attachments (Terms of Use)

  None (edit)
Comment 3 Amar Tumballi 2013-10-25 03:24:59 EDT
Hi Kevin, Nathan,

We have the string "There should be password-less SSH access between the node from which this command is run and the slave_host specified in the above command." as expected.

We do the setup of required ssh keys by 'gsec_create' command, and 'push-pem' option while creating the geo-replication, which sets up the key in all the slave nodes from every master node automatically. We did develop this command for reducing the sys-admin work for the user of geo-rep users.

Let me know if you need any more information on this.
Comment 8 Divya 2013-11-08 06:44:32 EST
Hi Kevin,

Based on your comment 6, I have added information on key changes in "11.2.3. Pre-requisites" section [1].

Your comment 7 has 3 parts, so for "One note should be added to clean existing secret.pem files from /var/lib/glusterd/geo-replication dirs when there are issues with the keys."

I have added an Important note in "11.3.6. Deleting a Geo-replication Session" section [2].

Based on my discussion with Amar, the remaining comments are perceived to be engineering enhancements. Hence, requesting you a raise a eng enhancement bug.

Kindly confirm if the changes are fine, so that I can move this bug to ON_QA.

Regards,
Divya

[1]http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Minimum_Reqs.html

[2]http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Starting-Delete.html
Comment 9 Anjana Suparna Sriram 2013-11-11 03:53:26 EST
Hi Mohit,

Could you review the docs (Comment 8) and confirm if the changes made are ok.

Regards,
Anjana
Comment 10 Divya 2013-11-25 02:23:14 EST
Based on your comment 6, I have added information on key changes in "11.2.3. Pre-requisites" section [1].

Comment 7 has 3 parts, so for "One note should be added to clean existing secret.pem files from /var/lib/glusterd/geo-replication dirs when there are issues with the keys."

I have added an Important note in "11.3.6. Deleting a Geo-replication Session" section [2].

Based on my discussion with Amar, the remaining comments are perceived to be engineering enhancements. Hence, moving the bug to ON_QA.

[1]http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Preparation-Minimum_Reqs.html

[2]http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_Storage/2.1/html/Administration_Guide/chap-User_Guide-Geo_Rep-Starting-Delete.html
Comment 11 M S Vishwanath Bhat 2013-11-25 09:03:59 EST
The status command output has changed from 2.1 GA to update 1 bits. This needs to be updated in the doc as well. I am moving back to Assigned. Please move it back to ON_QA once the status and status detail output is updated in the doc.
Comment 12 Divya 2013-11-28 06:11:14 EST
Further to my discussion with eng and QA team regard to status output, it was decided to remove the status output from the documentation due to its sheer volume. The output per line also exceeds the allowed size in the doc template and overflows to the next line. Hence, moving the bug back to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.