Bug 1019515 - geo-replication status for some nodes is continually "checkpoint as of <date_time> not reached yet"
geo-replication status for some nodes is continually "checkpoint as of <date_...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
All Linux
high Severity high
: ---
: ---
Assigned To: Amar Tumballi
Vijaykumar Koppad
: ZStream
Depends On: 987272 1028675
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 19:00 EDT by Kevin Clevenger
Modified: 2014-12-23 01:55 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.40rhs-1
Doc Type: Bug Fix
Doc Text:
Previously, when a checkpoint was set on geo-replication session, it used to be never get completed in one of the replica pair, and the geo-replication status command used to display "checkpoint as of <date_time> not reached yet" for that particular node. With this update, we keep track of peer status in replica pair also by checking 'stime', which solves this problem. Also, considering the replica pair will not be syncing any data to remote node, we don't even show checkpoint status for this node.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:42:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Sudhir D 2013-10-25 09:56:32 EDT
This looks similar to bz 987272
Marking this as dependent on same.
Comment 6 Amar Tumballi 2013-11-04 05:50:15 EST
This issue is happening on the passive node of the replica, because of the issue in bug 987292. With that bug fixed, this also should get fixed.

https://code.engineering.redhat.com/gerrit/#/c/15085/
Comment 8 Vijaykumar Koppad 2013-11-12 02:34:44 EST
verfied on glusterfs-3.4.0.43rhs-1, now the status would be like this. For passive nodes it just show N/A

MASTER NODE                 MASTER VOL    MASTER BRICK      SLAVE                  STATUS     CHECKPOINT STATUS                                                           CRAWL STATUS
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
shaktiman.blr.redhat.com    master        /bricks/brick1    10.70.42.171::slave    Active     checkpoint as of 2013-11-12 12:54:06 is completed at 2013-11-12 12:56:59    Changelog Crawl
riverrun.blr.redhat.com     master        /bricks/brick2    10.70.42.225::slave    Passive    N/A                                                                         N/A
snow.blr.redhat.com         master        /bricks/brick4    10.70.42.229::slave    Passive    N/A                                                                         N/A
targarean.blr.redhat.com    master        /bricks/brick3    10.70.43.159::slave    Active     checkpoint as of 2013-11-12 12:54:06 is completed at 2013-11-12 12:55:59    Changelog Crawl
Comment 10 errata-xmlrpc 2013-11-27 10:42:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.