This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019519 - Recovery alert definition from alert definition template is lost on resources if alert to recover template is modified
Recovery alert definition from alert definition template is lost on resources...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Monitoring - Alerts (Show other bugs)
JON 3.1.2
Unspecified Unspecified
unspecified Severity high
: ER05
: JON 3.2.0
Assigned To: Jay Shaughnessy
Mike Foley
:
Depends On:
Blocks: 1025569
  Show dependency treegraph
 
Reported: 2013-10-15 19:35 EDT by Larry O'Leary
Modified: 2014-01-02 15:39 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1025569 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 512733 None None None Never

  None (edit)
Description Larry O'Leary 2013-10-15 19:35:01 EDT
Description of problem:
If a resource is using a recovery alert from an alert definition template and the "alert to recover" template is updated, the resource loses the link to the "alert to recover". The result is even though the resource's recovery alert is intact and supposed to be a direct copy of the alert template, it doesn't actually recover the alert it is defined to recover.

This is also true for newly added resources. When the alert template gets applied, even though the "alert to recover" is clearly defined in the alert definition template, it is set to -- None -- when viewed on the resource.

Version-Release number of selected component (if applicable):
4.4.0.JON312GA

How reproducible:
Always

Steps to Reproduce:
1.  Start JBoss ON 3.1.2 system.
2.  Create the following 2 alerts for the JBossAS plug-in's JBossAS Server resource alert template:

    1.  Alert _Name_: `Alert - One`
    
        *   _Condition Type_: _Availability Change_
        *   _Availability_: _Goes Down_
        *   Recovery _Disable When Fired_: _Yes_
        
    2.  Alert _Name_: `Recovery - One`
    
        *   _Condition Type_: _Availability Change_
        *   _Availability_: _Goes Up_
        *   _Recovery Alert_: _Alert - One_
        
3.  Edit _Alert - One_ template and add the following condition and then remove the existing _Availability [Goes Down]_ condition:

    *   _Condition Type_: _Availability Duration_
    *   _Availability Duration_: _Stays Down_
    *   _Duration_: `1` _minutes_

4.  Import the RHQ Server resource from discovery queue.
5.  Navigate to the _alert definition_ page of the newly imported RHQ Server resource.
6.  View the recovery details tab of the _Recovery - One_ alert defiintion.

Actual results:
Recovery - One alert definition has its _Recover Alert_ set to -- None -- and does not recover the "Alert - One" if triggered.

Expected results:
Recovery - One alert definition has its _Recover Alert_ set to Alert - One and re-enables it if "Alert - One" has been triggered.

Additional info:
The order of these steps seems to be important. For example, an additional edit to _Recovery - One_ and re-selecting _Alert - One_ as its recover alert seems to clear this up. Then subsequent edits to Alert - One doesn't reintroduce this behavior. But, if another alert is added to the alert template, it can re-introduce the behavior if _Alert - One_ is updated again.
Comment 2 Jay Shaughnessy 2013-11-01 17:13:27 EDT
release/jon3.2.x commit 63e7d512e02c005b0a31e064a58d6338915f1aa0
Author: Jay Shaughnessy <jshaughn@redhat.com>
Date:   Fri Nov 1 17:04:58 2013 -0400

    Ensure that the to-be-recovered alert def is applied to the resource before
    the recovery alert def.

    Cherry-Pick master: 1255061fbdb257f2a7a79f407e498411ce904edc
Comment 3 Simeon Pinder 2013-11-06 21:17:46 EST
Moving to ON_QA for test with new brew build.
Comment 4 Filip Brychta 2013-11-08 04:40:54 EST
Verified on
Version :	
3.2.0.ER5
Build Number :	
2cb2bc9:225c796

Note You need to log in before you can comment on or make changes to this bug.