Bug 1019543 - radeonsi: Monitors on HDMI not recognized with xrandr on Radeon HD 7700 (Cape Verde)
radeonsi: Monitors on HDMI not recognized with xrandr on Radeon HD 7700 (Cape...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-15 23:36 EDT by Jean-François Fortin Tam
Modified: 2014-08-20 23:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-20 23:50:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (111.70 KB, text/x-log)
2013-10-15 23:36 EDT, Jean-François Fortin Tam
no flags Details
dmesg (84.53 KB, text/plain)
2013-10-15 23:37 EDT, Jean-François Fortin Tam
no flags Details
lspci -vvvv (20.31 KB, text/plain)
2013-10-15 23:37 EDT, Jean-François Fortin Tam
no flags Details

  None (edit)
Description Jean-François Fortin Tam 2013-10-15 23:36:15 EDT
With my Radeon HD 7770 and the open radeonsi driver (on Kernel 3.11.x), I am unable to output to an HDTV using HDMI. Only DVI works.

GNOME's display settings never "sees" the additional screen, and xrandr always thinks that the HDMI port is disconnected, like so:


Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
DisplayPort-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 598mm x 336mm
   1920x1080      60.0*+
   1280x1024      60.0  
   1440x900       59.9  
   1280x800       59.9  
   1152x864       75.0  
   1024x768       70.1     60.0  
   800x600        60.3     56.2  
   640x480        66.7     60.0  
   720x400        70.1
Comment 1 Jean-François Fortin Tam 2013-10-15 23:36:53 EDT
Created attachment 812727 [details]
Xorg log
Comment 2 Jean-François Fortin Tam 2013-10-15 23:37:21 EDT
Created attachment 812728 [details]
dmesg
Comment 3 Jean-François Fortin Tam 2013-10-15 23:37:58 EDT
Created attachment 812729 [details]
lspci -vvvv
Comment 4 Jean-François Fortin Tam 2013-11-21 19:44:05 EST
Issue persists in F20.
Comment 5 Jean-François Fortin Tam 2013-11-22 12:10:19 EST
Interestingly enough, this is not an issue if the HDMI cable was plugged in at poweron/boot time instead of hotplugged: when cold-plugged, both screens are turned on.
Comment 6 Jean-François Fortin Tam 2014-08-20 23:50:38 EDT
Turns out it was a physical PEBKAC with the connector.

Note You need to log in before you can comment on or make changes to this bug.