Bug 1019620 - Sony Walkman not accessable as MTP device
Sony Walkman not accessable as MTP device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
: 1033936 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 03:30 EDT by Oliver Sampson
Modified: 2016-01-03 13:14 EST (History)
6 users (show)

See Also:
Fixed In Version: libmtp-1.1.8-1.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-23 01:04:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Sampson 2013-10-16 03:30:20 EDT
Description of problem:
Sony Walkman NWZ-A816 is not recognized as an MTP Device

Version-Release number of selected component (if applicable):


How reproducible:
Every time.


Steps to Reproduce:
1. Attach Sony Walkman via USB
2. See Portable Media Notification in KDE
3. In Dolphin see error: The file or folder udi=/org/kde/solid/udev/sys/devices/pci0000:00/0000:00:14.0/usb3/3-3 does not exist.

Actual results:
Device unreachable via MTP

Expected results:
Browsable device via MTP.

Additional info:
It is attached and recognized.

Oct 16 09:21:27 Amadeus kernel: [22316.214785] usb 3-3: new high-speed USB device number 6 using xhci_hcd
Oct 16 09:21:27 Amadeus kernel: [22316.227044] usb 3-3: New USB device found, idVendor=054c, idProduct=0325
Oct 16 09:21:27 Amadeus kernel: [22316.227050] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Oct 16 09:21:27 Amadeus kernel: [22316.227052] usb 3-3: Product: WALKMAN
Oct 16 09:21:27 Amadeus kernel: [22316.227054] usb 3-3: Manufacturer: Sony
Oct 16 09:21:27 Amadeus kernel: [22316.227056] usb 3-3: SerialNumber: 491DE5011557
Oct 16 09:21:27 Amadeus kernel: [22316.227915] usb-storage 3-3:1.0: USB Mass Storage device detected
Oct 16 09:21:27 Amadeus kernel: [22316.228070] scsi9 : usb-storage 3-3:1.0
Comment 1 Oliver Sampson 2013-10-16 03:49:55 EDT
FWIW,
on another try there's a whole bunch of similar messsages in the logfile that look like:

ct 16 09:46:00 Amadeus kernel: [  513.146793] usb 1-1.2: usbfs: process 6237 (kio_mtp) did not claim interface 0 before use
Oct 16 09:46:00 Amadeus kernel: [  513.221552] usb 1-1.2: reset high-speed USB device number 14 using ehci-pci
Oct 16 09:46:00 Amadeus kernel: [  513.307850] usb 1-1.2: usbfs: process 6237 (kio_mtp) did not claim interface 0 before use

During this, Dolphin was saying that it was loading the directory and then ended with "The process for the mtp protocol died unexpectedly."
Comment 2 Simon Lewis 2013-11-25 10:02:32 EST
*** Bug 1033936 has been marked as a duplicate of this bug. ***
Comment 3 Simon Lewis 2013-11-25 10:07:56 EST
I have built and tested kio_mtp from git2063e757 dated 20.10.2013 and confirm that, at least for my system:

- the bug was in the fc19 repo version of kio_mtp

- the bug has been fixed in the git of kio_mtp

- the bug is in kio_mtp and not libmtp



Simon
Comment 4 Jan Grulich 2013-12-13 09:37:49 EST
Is this bug still present with kio_mtp-0.75-4.20131020git2063e75?
Comment 5 Oliver Sampson 2013-12-15 14:22:58 EST
Yes. There are some other messages in the log, but the behavior is exactly the same.

Dec 15 20:15:29 Amadeus kernel: [53237.718781] usb 3-3: new high-speed USB device number 17 using xhci_hcd
Dec 15 20:15:29 Amadeus kernel: [53237.730902] usb 3-3: New USB device found, idVendor=054c, idProduct=0325
Dec 15 20:15:29 Amadeus kernel: [53237.730908] usb 3-3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Dec 15 20:15:29 Amadeus kernel: [53237.730911] usb 3-3: Product: WALKMAN
Dec 15 20:15:29 Amadeus kernel: [53237.730913] usb 3-3: Manufacturer: Sony
Dec 15 20:15:29 Amadeus kernel: [53237.730914] usb 3-3: SerialNumber: 491DE5011557
Dec 15 20:15:29 Amadeus kernel: [53237.731628] usb-storage 3-3:1.0: USB Mass Storage device detected
Dec 15 20:15:29 Amadeus kernel: [53237.732401] scsi7 : usb-storage 3-3:1.0
Dec 15 20:16:47 Amadeus kernel: [53315.094423] usb 3-2.1.4: usbfs: process 31332 (kio_mtp) did not claim interface 0 before use
Dec 15 20:16:47 Amadeus kernel: [53315.157092] usb 3-2.1.4: reset high-speed USB device number 16 using xhci_hcd
Dec 15 20:16:47 Amadeus kernel: [53315.168963] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e340
Dec 15 20:16:47 Amadeus kernel: [53315.168966] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e300
Dec 15 20:16:47 Amadeus kernel: [53315.168968] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e380
Dec 15 20:16:47 Amadeus kernel: [53315.170063] usb 3-2.1.4: usbfs: process 31332 (kio_mtp) did not claim interface 0 before use
Dec 15 20:18:47 Amadeus kernel: [53435.410939] usb 3-2.1.4: reset high-speed USB device number 16 using xhci_hcd
Dec 15 20:18:47 Amadeus kernel: [53435.423482] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e340
Dec 15 20:18:47 Amadeus kernel: [53435.423499] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e300
Dec 15 20:18:47 Amadeus kernel: [53435.423502] xhci_hcd 0000:00:14.0: xHCI xhci_drop_endpoint called with disabled ep ffff8803fd84e380
Comment 6 Fedora Update System 2014-08-30 15:16:36 EDT
libmtp-1.1.8-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/libmtp-1.1.8-1.fc21
Comment 7 Fedora Update System 2014-09-01 15:45:21 EDT
Package libmtp-1.1.8-1.fc21:
* should fix your issue,
* was pushed to the Fedora 21 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmtp-1.1.8-1.fc21'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-9984/libmtp-1.1.8-1.fc21
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-09-23 01:04:06 EDT
libmtp-1.1.8-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Oliver Sampson 2016-01-03 13:14:21 EST
After a long time of not having tried to use this Walkman with Fedora, I've given it another try on Fedora 22 and it still doesn't work. Sorry for the late report.

[349748.211444] usb 3-1.2: new high-speed USB device number 4 using ehci-pci
[349748.299057] usb 3-1.2: New USB device found, idVendor=054c, idProduct=0325
[349748.299062] usb 3-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[349748.299064] usb 3-1.2: Product: WALKMAN
[349748.299066] usb 3-1.2: Manufacturer: Sony
[349748.299068] usb 3-1.2: SerialNumber: 491DE5011557
[349748.349381] usb-storage 3-1.2:1.0: USB Mass Storage device detected
[349748.349488] scsi host6: usb-storage 3-1.2:1.0
[349748.349592] usbcore: registered new interface driver usb-storage
[349777.560740] usb 1-3.1.4: usbfs: process 27833 (kio_mtp) did not claim interface 0 before use
[349777.634162] usb 1-3.1.4: reset high-speed USB device number 26 using xhci_hcd
[349777.708634] usb 1-3.1.4: usbfs: process 27833 (kio_mtp) did not claim interface 0 before use
[349898.009742] usb 1-3.1.4: reset high-speed USB device number 26 using xhci_hcd

with libmtp-1.1.9-1.fc22.x86_64

Note You need to log in before you can comment on or make changes to this bug.