Bug 1019673 - unable to create new bundle via uploading receipe file
unable to create new bundle via uploading receipe file
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Provisioning (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity urgent
: ---
: JON 3.2.0
Assigned To: John Mazzitelli
Mike Foley
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 04:46 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 11:47:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
generatedBundle (1.04 KB, application/zip)
2013-10-16 04:47 EDT, Armine Hovsepyan
no flags Details
bundleRecipe2 (178 bytes, text/plain)
2013-10-16 04:48 EDT, Armine Hovsepyan
no flags Details
WorkingBundle (3.71 KB, application/zip)
2013-10-16 05:03 EDT, Armine Hovsepyan
no flags Details
Screenshot (8.68 KB, image/png)
2013-10-16 11:44 EDT, Heiko W. Rupp
no flags Details

  None (edit)
Description Armine Hovsepyan 2013-10-16 04:46:12 EDT
Description of problem:
unable to create new bundle

Version-Release number of selected component (if applicable):
jon 3.2 er3

How reproducible:
always

Steps to Reproduce:
1. navigate to bundles -> click "new" button
2. upload recipe file (attached examples)
3. click "next" button

Actual results:
the following exception thrown:
java.lang.Exception:Failed to parse the bundle Ant script. -> org.rhq.bundle.ant.InvalidBuildFileException:The deployment unit must specifically declare compliance mode of the destination directory

screen-shot ->  http://d.pr/i/Zz1f

Expected results:
recipe uploaded, bundle creation/installation is possible


Additional info:
example bundles attached
Comment 1 Armine Hovsepyan 2013-10-16 04:47:16 EDT
Created attachment 812827 [details]
generatedBundle
Comment 2 Armine Hovsepyan 2013-10-16 04:48:05 EDT
Created attachment 812828 [details]
bundleRecipe2
Comment 3 Armine Hovsepyan 2013-10-16 05:03:31 EDT
Created attachment 812832 [details]
WorkingBundle
Comment 4 Armine Hovsepyan 2013-10-16 05:06:33 EDT
attached WorkingBundle - having recipe without ant script (target tags in xml)
Comment 5 John Mazzitelli 2013-10-16 11:40:21 EDT
see 

https://docs.jboss.org/author/display/RHQ/Ant+Bundles#AntBundles-rhq%3Adeploymentunit

"compliance 	This is a new required attribute (as of RHQ 4.9.0)"

Any new bundles you create in the new JON/RHQ must have this required attribute - if not, the bundle will be rejected.
Comment 6 Heiko W. Rupp 2013-10-16 11:44:05 EDT
Apparently the zipped bundles and the recipe upload use different error messages. The attachment shows how this looks for the zipped-bundle for me.
Comment 7 Heiko W. Rupp 2013-10-16 11:44:47 EDT
Created attachment 813015 [details]
Screenshot
Comment 8 John Mazzitelli 2013-10-16 11:47:59 EDT
this bug is not a bug. the error message is fine and shows in the UI.

I created another BZ that is related but different - if you upload the bundle in a .zip format, you get a shorter error that is less descriptive

see bug #1019917

but if you are uploading a recipe, there is no bug. hence, this BZ will be closed.

Note You need to log in before you can comment on or make changes to this bug.