Bug 10197 - pilot-xfer fails to bind to serial port with kernel-2.2.14
Summary: pilot-xfer fails to bind to serial port with kernel-2.2.14
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: pilot-link (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-16 01:53 UTC by Matthew Saltzman
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 14:21:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Saltzman 2000-03-16 01:53:53 UTC
The pilot-xfer program fails with the following message:

    [mjs@yankee ~]: pilot-xfer --backup .
    Unable to bind to port '/dev/pilot'.
    (Please see 'man pilot-xfer' or 'pilot-xfer --help' for information
on      setting the port).

This occurs when running with a kernel compiled from 2.2.14-1.5.0 sources.
The problem does *not* occur when running with the stock 6.1
kernel-2.2.12-20.  /dev/pilot is a symbolic link to /dev/ttyS2, which
is in turn

    crw-------   1 mjs      tty        4,  66 Mar 14 16:42 /dev/ttyS2

The problem also occurs when /dev/pilot is a device in its own right
with the same configuration.  The userid running pilot-xfer is mjs.

Note that both the kernel and the pilot-link-0.9.3-2 RPM were rebuilt
on a stock (updated) RH6.1 system.  In particular, I have stock RH6.1
libraries, including glibc-2.1.2-11, and egcs-1.1.2-24.  The problem
also occurs with the stock RH6.1 pilot-link RPM, which is why I tried
the upgrade.

Comment 1 Matthew Saltzman 2000-04-14 01:00:59 UTC
OK It's not a bug.  Works fine under the real RH6.2.

"Never mind..."


Note You need to log in before you can comment on or make changes to this bug.