Bug 1019746 - ipsec ikeping does not recognize --exchangenum parameter
ipsec ikeping does not recognize --exchangenum parameter
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openswan (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Paul Wouters
Aleš Mareček
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 06:51 EDT by Ondrej Moriš
Modified: 2014-10-14 04:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 04:18:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Moriš 2013-10-16 06:51:47 EDT
Description of problem:

When --exchange parameter [*] is used with ipsec ikeping, it seems not to be recognized correctly. Moreover with unrecognized parameter ipsec ikeping aborts.

[*]  [--exchangenum num]    use num instead of 244 for the exchange type.

Version-Release number of selected component (if applicable):

openswan-2.6.32-25.el6

How reproducible:

100%

Steps to Reproduce:

0. make sure ipsec is stopped
1. ipsec ikeping --thisoptiondoesnotexist 1.2.3.4
2. ipsec ikeping --exchangenum 245 1.2.3.4

Actual results:

1. /usr/libexec/ipsec/ikeping: unrecognized option '--thisoptiondoesnotexist'
   ikeping: /builddir/build/BUILD/openswan-2.6.32/programs/ikeping/ikeping.c:396: main: Assertion `0' failed.
   Aborted (core dumped)
2. ikeping: /builddir/build/BUILD/openswan-2.6.32/programs/ikeping/ikeping.c:396: main: Assertion `0' failed.
   Aborted (core dumped)

Expected results:

1. ipsec ikeping: unknown option '--thisoptiondoesnotexist'
2. ipsec ikeping: unknown option `--exchangenum'


Additional info:

This is not a regression.
Comment 1 Paul Wouters 2013-10-16 11:52:08 EDT
This was fixed in libreswan upstream last week:

https://github.com/libreswan/libreswan/commit/c5b9334167795c7a683c4a6630770fa323ee2750

I can put it in if/when we do a 6.6 release. libreswan in rhel7 will have the fix
Comment 4 errata-xmlrpc 2014-10-14 04:18:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1588.html

Note You need to log in before you can comment on or make changes to this bug.