Bug 1019758 - [DWH] installation - misleading message
[DWH] installation - misleading message
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Barak Dagan
integration
: EasyFix, Triaged
Depends On:
Blocks: 3.3snap2
  Show dependency treegraph
 
Reported: 2013-10-16 07:10 EDT by Pavel Stehlik
Modified: 2014-07-13 19:19 EDT (History)
8 users (show)

See Also:
Fixed In Version: is21
Doc Type: Bug Fix
Doc Text:
A warning message misled users to think a database backup would take hours when the process only took several seconds. The message is now more specific, and only warns users of a long backup duration in specific cases, such as if the database size is large.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 10:01:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20256 None None None Never

  None (edit)
Description Pavel Stehlik 2013-10-16 07:10:15 EDT
Description of problem:
Please rephrase these sentences: 
 ...The detected DB size is 51993 Mb. This process can take a considerable time, and in some cases may take few hours to complete...

From above one can feel, that after analyse (Detected DB size - 50MB) this specific amount of data could take like an hour. If installer is not analysing anything, maybe better formulate sentences similar to:
"... The detected DB size is 52 MB. In some specific cases backup may take few hours to complete..."

This process of backup for 50MB took 2s.


Of course more precise estimation would be nice, however I think for such significant change is a bit late.


Version-Release number of selected component (if applicable):
is18.1

How reproducible:


Steps to Reproduce:
1. install rhevm-dwh, rhevm-reports
2. run rhevm-dwh-setup again
3.

Actual results:


Expected results:


Additional info:
Comment 1 Barak 2013-10-22 04:49:57 EDT
Arthur please consult on the message format.
Comment 3 Barak Dagan 2013-10-31 12:57:10 EDT
Verified on IS21:

The upgrade utility can backup the existing database. The time and space required for the database backup depend on its size. The detected DB size is 25 MB. This process takes time, and in some cases (for instance, when the size is few GBs) may take few hours to complete. Would you like to continue and backup the existing database?
Comment 4 Charlie 2013-11-27 19:54:26 EST
This bug is currently attached to errata RHEA-2013:15116. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 errata-xmlrpc 2014-01-21 10:01:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0036.html

Note You need to log in before you can comment on or make changes to this bug.