This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1019764 - System's description length exceeds 255 characters
System's description length exceeds 255 characters
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.2
Unspecified Unspecified
medium Severity low (vote)
: Unspecified
: --
Assigned To: Christine Fouant
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-16 07:13 EDT by Sachin Ghai
Modified: 2016-04-22 11:41 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:06:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
description length exceeds 255 characters (82.98 KB, image/png)
2013-10-16 07:13 EDT, Sachin Ghai
no flags Details
error on exceeding sys description more than 1000 char (64.35 KB, image/png)
2014-06-18 02:09 EDT, Sachin Ghai
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6223 None None None 2016-04-22 11:41 EDT

  None (edit)
Description Sachin Ghai 2013-10-16 07:13:56 EDT
Created attachment 812867 [details]
description length exceeds 255 characters

Description of problem:
I can set the system's description more than 255 characters. There should be some limit set on it.

Version-Release number of selected component (if applicable):
snap5 compose2 (MDP2)
katello-1.4.6-31.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. create a system
2. edit system description with more than 255 characters
3.

Actual results:
No limit set on description as user can enter more than 255 characters

Expected results:
there should be some limit as it was set in old UI

Additional info:
Comment 2 Christine Fouant 2014-06-13 18:51:22 EDT
Created redmine issue http://projects.theforeman.org/issues/6223 from this bug
Comment 3 Partha Aji 2014-06-17 18:35:46 EDT
Sachin,
The systens description Max length was changed to 1000 characters. That is the reason its not complaining at 255 for you. Please fail the bug if it doesnot complain after crossing  1000
Comment 4 Sachin Ghai 2014-06-18 02:08:11 EDT
Thank you Partha for confirming the limit. So as you said, UI does complain on exceeding the description length more than 1000 char. Moving this to verified.
Comment 5 Sachin Ghai 2014-06-18 02:09:17 EDT
Created attachment 909848 [details]
error on exceeding sys description more than 1000 char
Comment 6 Bryan Kearney 2014-07-02 10:06:44 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.

Note You need to log in before you can comment on or make changes to this bug.